Bug 809822 - EWD is hit 30 minutes before expected test-time
EWD is hit 30 minutes before expected test-time
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.8
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 09:08 EDT by Jan Stancek
Modified: 2012-04-04 13:13 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 13:13:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stancek 2012-04-04 09:08:19 EDT
Description of problem:
Expected test-time for test is set to "2h". After ~90m beaker aborts jobs with: 
External Watchdog Expired

Version-Release number of selected component (if applicable):
0.8.1

How reproducible:
unknown, this test usually completes sooner than 90m

Steps to Reproduce:
1. set test-time to 2h 
2. make reboot during test and make sure reboot takes longer than ~20 minutes.
  
Actual results:
Job is aborted with EWD

Expected results:
Job should be allowed to run for test-time

Additional info:
Comment 4 Bill Peck 2012-04-04 10:49:21 EDT
Looks like the test is doing this..

# Step 1b: Push watchdog out
if [ -z "${REBOOTCOUNT}" ] || [ "${REBOOTCOUNT}" -eq 0 ]; then
    echo "ACTION: pushing watchdog out" | tee -a ${OUTPUTFILE}
    ./extend.py $LAB_CONTROLLER $TESTID 5400
fi

5400 is 1 hour and 30 minutes..

I would update the test to remove that.
Comment 5 Jan Stancek 2012-04-04 12:55:32 EDT
(In reply to comment #4)
> Looks like the test is doing this..
> 
> # Step 1b: Push watchdog out
> if [ -z "${REBOOTCOUNT}" ] || [ "${REBOOTCOUNT}" -eq 0 ]; then
>     echo "ACTION: pushing watchdog out" | tee -a ${OUTPUTFILE}
>     ./extend.py $LAB_CONTROLLER $TESTID 5400
> fi
> 
> 5400 is 1 hour and 30 minutes..
> 
> I would update the test to remove that.

Thanks Bill, this looks like (my) user error, feel free to close this as NOTABUG.
Comment 6 Bill Peck 2012-04-04 13:13:16 EDT
no worries. :-)

Note You need to log in before you can comment on or make changes to this bug.