Bug 809831 - Failed to resume from hibernation when SWAP size < RAM size.
Failed to resume from hibernation when SWAP size < RAM size.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 09:34 EDT by Dee'Kej
Modified: 2012-04-04 14:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 09:55:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dee'Kej 2012-04-04 09:34:16 EDT
Description of problem:
Fedora failed to resume normally from hibernation. In the middle of resume it restarted itself.

Bug found during Fedora testing day, Fedora was booted from provided USB stick and the used SWAP partition was of my SSD disk. I have 8 GB RAM and 4 GB SWAP partition. (Hibernation works for me fine with Linux Mint 11 x64.)


Version-Release number of selected component (if applicable):


How reproducible:
This bug probably depends very much on HW configuration, so it might not be easy to reproduce. My HW configuration can be found in the link below.


Steps to Reproduce:
1. Use USB stick with Fedora 17, boot it.
2. Hibernate system.
3. Power again.
  
Actual results:
Resume from hibernation failed, computer was restarted.

Expected results:
Resume from hibernation would not fail.

Additional info:
link to results (user Dee'Kej):
https://fedoraproject.org/wiki/Test_Day:2012-04-04_Power_Management#Test_Results
Comment 1 Josh Boyer 2012-04-04 09:55:32 EDT
We can't really do much about this kind of setup.  The hibernate image is normally compressed so it might fit in the smaller swap area, but it is highly dependent on the workload at hibernation time and how much memory is used.
Comment 2 Dee'Kej 2012-04-04 14:54:35 EDT
Of course, I understand. I was just told to report it in case it was a bug at Today's testing day (I was at Red Hat Brno bureau.). Anyway, thx for reply.

Note You need to log in before you can comment on or make changes to this bug.