Bug 809889 - [abrt] libreoffice-core-3.5.2.1-1.fc17: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.2.1-1.fc17: Process /usr/lib64/libreoffice/progra...
Status: CLOSED DUPLICATE of bug 680063
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:7a92f6b9d261a4d00de07c9e451...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 11:05 EDT by Jonathan Kamens
Modified: 2012-04-05 08:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 08:26:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (13.19 KB, text/plain)
2012-04-04 11:05 EDT, Jonathan Kamens
no flags Details
File: backtrace (122.24 KB, text/plain)
2012-04-04 11:05 EDT, Jonathan Kamens
no flags Details
File: maps (93.88 KB, text/plain)
2012-04-04 11:05 EDT, Jonathan Kamens
no flags Details
File: dso_list (20.12 KB, text/plain)
2012-04-04 11:05 EDT, Jonathan Kamens
no flags Details
File: build_ids (7.45 KB, text/plain)
2012-04-04 11:05 EDT, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2012-04-04 11:05:05 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --draw file:///home/jik/Dropbox/Bayla/invitation%20recolored.odg --splash-pipe=6
comment:        I was in the process of loading a new color palette in Draw. While the file chooser window was open to choose which .soc file to open, I created and saved a *new* .soc file in that directory, using a text editor separate from LibreOffice. When I saved the new .soc file, LibreOffice crashed.
crash_function: gtk_file_system_model_iter_nth_child
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.3.0-8.fc17.x86_64
pid:            15949
pwd:            /home/jik
remote_result:  NOTFOUND
time:           Tue 03 Apr 2012 11:24:40 PM EDT
uid:            3009
username:       jik
xsession_errors: 

backtrace:      Text file, 125174 bytes
build_ids:      Text file, 7626 bytes
core_backtrace: Text file, 13507 bytes
dso_list:       Text file, 20599 bytes
maps:           Text file, 96129 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/jik/35

environ:
:XDG_VTNR=2
:MANPATH=/home/jik/man:/usr/local/share/man:/usr/share/man:/home/jik/man:/usr/local/share/man:/usr/share/man:/usr/man
:NNTPSERVER=jik3.kamens.brookline.ma.us
:XDG_SESSION_ID=35
:HOSTNAME=jik2.kamens.brookline.ma.us
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=15935
:GPG_AGENT_INFO=/home/jik/.cache/keyring-EPcPc4/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-5635-jik2.kamens.brookline.ma.us-libreoffice-31_TIME204809472
:HISTSIZE=1000
:XDG_SESSION_COOKIE=8410e26ea99d7673240015d34b2a4789-1333305294.759098-1748438068
:PGPPATH=/home/jik/.pgpdata
:OLDPWD=/usr/lib64/libreoffice/program
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/home/jik/.cache/keyring-EPcPc4
:QTINC=/usr/lib64/qt-3.3/include
:IMSETTINGS_MODULE=none
:USER=jik
:OBAMA_PASS=aplflpy
:SSH_AUTH_SOCK=/home/jik/.cache/keyring-EPcPc4/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/5417,unix/unix:/tmp/.ICE-unix/5417
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-draw.desktop
:MAIL=/var/mail/jik
:PATH=/home/jik/bin:/home/jik/scripts:/usr/games:/usr/lib64/qt-3.3/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:LC_COLLATE=C
:PWD=/home/jik
:XMODIFIERS=@im=none
:EDITOR=emacsclient
:KDE_IS_PRELINKED=1
:GNOME_KEYRING_PID=5412
:LANG=en_US
:KDEDIRS=/usr
:HEBCAL_CITY=Boston
:GDMSESSION=gnome
:MAILHOST=jik
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:TEXINPUTS=.:/home/jik/tex:/usr/lib/texmf/tex/language/hebrew:
:XDG_SEAT=seat0
:HOME=/home/jik
:SHLVL=1
:OBAMA_GROUP=JewsforObama
:AUDIOT=/dev/dsp1
:OBAMA_USER=jik-barack@kamens.brookline.ma.us
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=jik
:VISUAL=emacsclient
:QTLIB=/usr/lib64/qt-3.3/lib
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-PB8XkJTQEw,guid=9fdc55e895aedf95e7476222000002c6
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:XDG_RUNTIME_DIR=/run/user/jik
:DISPLAY=:0.0
:P4CONFIG=.p4conf
:CCACHE_HASHDIR=
:XAUTHORITY=/var/run/gdm/auth-for-jik-whBMeS/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        unlimited            unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 95909                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         4294967296           4294967296           bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       95909                95909                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     20                   20                   
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/jik/.xsession-errors
:pos:	125299
:flags:	0102002
:2:/home/jik/.xsession-errors
:pos:	125299
:flags:	0102002
:3:socket:[4983200]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:pipe:[4983159]
:pos:	0
:flags:	00
:6:pipe:[4983159]
:pos:	0
:flags:	01
:7:socket:[4981749]
:pos:	0
:flags:	02000002

smolt_data:
:
:
:General
:=================================
:UUID: 9aa48111-c83b-44ff-8d44-2ec6e3aaa25a
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US
:Platform: x86_64
:BogoMIPS: 5242.88
:CPU Vendor: GenuineIntel
:CPU Model: Pentium(R) Dual-Core  CPU      E5300  @ 2.60GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2603
:System Memory: 12018
:System Swap: 0
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.3.0-8.fc17.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:11808:4163:33491) pci, None, HOST/PCI, 4 Series Chipset DRAM Controller
:(32902:11809:4163:33491) pci, pcieport, PCI/PCI, 4 Series Chipset PCI Express Root Port
:(32902:14896:4163:33492) pci, None, SERIAL, 82801JI (ICH10 Family) SMBus Controller
:(32902:14880:4163:33492) pci, ata_piix, STORAGE, 82801JI (ICH10 Family) 4 port SATA IDE Controller #1
:(32902:14872:4163:33492) pci, None, PCI/ISA, 82801JIB (ICH10) LPC Interface Controller
:(32902:14886:4163:33492) pci, ata_piix, STORAGE, 82801JI (ICH10 Family) 2 port SATA IDE Controller #2
:(4332:33128:4163:33639) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:14901:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #2
:(32902:9294:4163:33492) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:14905:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #6
:(32902:14902:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #3
:(32902:14906:4163:33492) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #1
:(32902:14908:4163:33492) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #2
:(4523:24833:4163:33504) pci, pata_marvell, STORAGE, 88SE6101/6102 single-port PATA133 interface
:(32902:14912:4163:33492) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 1
:(32902:14920:4163:33492) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 5
:(32902:14910:4163:33658) pci, snd_hda_intel, MULTIMEDIA, 82801JI (ICH10 Family) HD Audio Controller
:(32902:14903:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #4
:(32902:14900:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #1
:(4318:1764:14402:51000) pci, nouveau, VIDEO, G98 [GeForce 8400 GS]
:(32902:14922:4163:33492) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 6
:(4332:33081:4332:33081) pci, 8139too, ETHERNET, RTL-8139/8139C/8139C+
:(4332:33129:4997:12570) pci, r8169, ETHERNET, GA311
:(32902:14904:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_jik2-lv_root / ext4 4096 4096 51150223 12369032 11857193 12804096 11885585 11885585
:/dev/mapper/vg_jik2-lv_share WITHHELD ext4 4096 4096 190312883 186661741 177092583 47849472 47471134 47471134
:/dev/mapper/vg_jik2-lv_root WITHHELD ext4 4096 4096 51150223 12369032 11857193 12804096 11885585 11885585
:/dev/mapper/vg_jik2-lv_root WITHHELD ext4 4096 4096 51150223 12369032 11857193 12804096 11885585 11885585
:/dev/mapper/vg_jik2-lv_root WITHHELD ext4 4096 4096 51150223 12369032 11857193 12804096 11885585 11885585
:/dev/sda1 /boot ext4 1024 1024 202770 127516 117277 51200 50897 50897
:/dev/sdb1 WITHHELD ext4 4096 4096 39020599 13549456 11595852 9773056 8135991 8135991
:/dev/sdb1 WITHHELD ext4 4096 4096 39020599 13549456 11595852 9773056 8135991 8135991
:

var_log_messages:
:Apr  1 14:34:46 jik2 kernel: [  702.623625] soffice.bin[5231]: segfault at 49692d50 ip 0000003e17a38b11 sp 00007f899d80da00 error 4 in libc-2.15.so[3e17a00000+1ac000]
:Apr  1 14:34:49 jik2 abrt[5290]: Saved core dump of pid 5224 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-04-01-14:34:46-5224 (128397312 bytes)
:Apr  3 23:24:40 jik2 kernel: [205296.657519] soffice.bin[15949]: segfault at 108027fc8bc ip 0000003e351002bc sp 00007fffbddee940 error 4 in libgtk-x11-2.0.so.0.2400.10[3e35000000+467000]
:Apr  3 23:24:43 jik2 abrt[16059]: Saved core dump of pid 15949 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-04-03-23:24:40-15949 (135131136 bytes)
Comment 1 Jonathan Kamens 2012-04-04 11:05:11 EDT
Created attachment 575166 [details]
File: core_backtrace
Comment 2 Jonathan Kamens 2012-04-04 11:05:12 EDT
Created attachment 575167 [details]
File: backtrace
Comment 3 Jonathan Kamens 2012-04-04 11:05:14 EDT
Created attachment 575168 [details]
File: maps
Comment 4 Jonathan Kamens 2012-04-04 11:05:16 EDT
Created attachment 575169 [details]
File: dso_list
Comment 5 Jonathan Kamens 2012-04-04 11:05:17 EDT
Created attachment 575170 [details]
File: build_ids
Comment 6 Caolan McNamara 2012-04-05 08:26:53 EDT

*** This bug has been marked as a duplicate of bug 680063 ***

Note You need to log in before you can comment on or make changes to this bug.