This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 809894 - clean up error message for hwp insufficient permission to launch
clean up error message for hwp insufficient permission to launch
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Tzu-Mainn Chen
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 11:30 EDT by wes hayutin
Modified: 2012-12-04 10:02 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When an instance was launched with insufficient permission, duplicate error messages occurred. This bug fix updates deployment.rb and displays the right error message: "You have insufficient privileges to perform the selected action"
Story Points: ---
Clone Of: 807342
Environment:
Last Closed: 2012-12-04 10:02:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image admin user attempting to launch an instance (53.19 KB, image/png)
2012-09-20 12:17 EDT, Ronelle Landy
no flags Details

  None (edit)
Comment 1 Tzu-Mainn Chen 2012-04-04 11:36:50 EDT
Patch created:

https://fedorahosted.org/pipermail/aeolus-devel/2012-April/009860.html
Comment 2 Tzu-Mainn Chen 2012-04-09 09:37:24 EDT
Pushed to master:

commit 2009b40bd1a332ffabe76ec189dba70b4d3ecd70
BZ 809894 fix duplicate error message, I18n the error message

commit ffdebd7ef4a4e213a57a95801a89e283e4326f53
BZ 809894 added deployments.flash.error.no_hwp_permission
Comment 3 Tzu-Mainn Chen 2012-04-09 12:12:29 EDT
One added test fix:

commit 8a9e47b1b5aa7c7b21cd3ffaa2632963ae21bcbb
BZ 809894 update test to accomodate duplicate-error fix
Comment 6 Ronelle Landy 2012-09-20 12:17:06 EDT
Looking at comment 11 in BZ-807342 ... this appears to be the case. If the user has insufficient priviledges to launch an instance, Conductor simply tells the user so ( see attached screenshot).

As a user with 'insufficient privileges', I could not edit the blueprint to change the hwp, nor could I delete it, so it's hard to fall into a trouble case here ... marking the BZ verified.

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
Comment 7 Ronelle Landy 2012-09-20 12:17:49 EDT
Created attachment 614971 [details]
Image admin user attempting to launch an instance
Comment 9 errata-xmlrpc 2012-12-04 10:02:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.