Bug 809968 - Docs: Create narrative output
Docs: Create narrative output
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ---
: 6.0.0
Assigned To: Misha H. Ali
prabhat jha
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 14:47 EDT by mark yarborough
Modified: 2012-08-15 12:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 22:14:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark yarborough 2012-04-04 14:47:14 EDT
As of JDG6 Beta1 in April 2012, QE indicated that the topic-based 
navigation was very confusing. This is an important problem to fix
before GA, and it may take several tries due to the fragmented nature
of the topic-based approach and the subjective perception of "Good
navigation." Asking Misha to incorporate pre-Bz input from Pete Muir,
Alan Santos, Prabhat Jha and others into this bug as needed. Not sure
how to best review the result, but we should do it earlier than 6.0.0.CR1
and should probably involve the field as well (SA's and such). Please ping
PM or PGM as needed for help on setting up field reviews. How are other 
products (eg. EAP) reviewing the topic navigation? Thanks.
Comment 1 Misha H. Ali 2012-04-04 15:53:11 EDT
Discussion and resulting plans have determined that the current topic based format will not be used for GA. Instead, the same (and additional) content is to be mapped into multiple narrative books, namely:

1. Getting Started Guide
2. Administration and Configuration Guide
3. Developers Guide

The topic based content will only be used for the JDG beta release.
Comment 2 Misha H. Ali 2012-04-04 17:52:14 EDT
Additional decision, a post beta documentation release will occur (timeline undetermined currently but safe to say 1-2 weeks after beta release) where all topics included in beta documentation will be factored into a narrative document. Said narrative document will be released as an addition to the beta documentation suite.
Comment 5 prabhat jha 2012-04-15 21:13:49 EDT
Misha, I definitely like this better. I did not go through contents in details since I am assuming these are same from topic based approached that we went through in details.
Comment 6 prabhat jha 2012-04-15 21:23:46 EDT
It's good for beta. For GA, we would need more contents.

Note You need to log in before you can comment on or make changes to this bug.