Bug 810068 - During install, verifying database connection clears password
During install, verifying database connection clears password
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: Usability (Show other bugs)
JON 3.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 23:52 EDT by Joel Tosi
Modified: 2016-10-05 19:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-22 12:30:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Tosi 2012-04-04 23:52:42 EDT
Description of problem:
When you are installing JON, you first verify the database connection (or could / should).  If you do that, the page refreshes and even if the connection is successful, the password is cleared.  A user not paying attention to this would just see the 'test succeeded' and want to proceed with install, but that would fail since the password was cleared.

Version-Release number of selected component (if applicable):
JON 3.0

How reproducible:
Do a clean install of JON
At install screen, verify database connection
Notice that password is cleared during screen refresh

Steps to Reproduce:
1.Clean install of JON
2.At install screen, enter valid database credentials
3.Test database connection
4.Upon success, finish install
5.Get error

  
Actual results:
Error because password was cleared after successful connection test

Expected results:
After successful test connection, I should be able to go right into install without having to reenter password.

Additional info:
Comment 1 John Mazzitelli 2013-04-22 12:30:01 EDT
the GUI installer has gone away in the next version, so this BZ is outdated and obsolete.

Note You need to log in before you can comment on or make changes to this bug.