Bug 810153 - FTBFS: build failure on PPC, error: '__start___verbose' undeclared
FTBFS: build failure on PPC, error: '__start___verbose' undeclared
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: corosync (Show other bugs)
rawhide
powerpc Linux
urgent Severity high
: ---
: ---
Assigned To: Steven Dake
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 05:51 EDT by Karsten Hopp
Modified: 2016-04-26 11:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 09:54:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
chech for the section before using it (883 bytes, patch)
2012-04-05 09:38 EDT, Angus Salkeld
no flags Details | Diff

  None (edit)
Description Karsten Hopp 2012-04-05 05:51:25 EDT
Description of problem:
A build on PPC64 aborted with this error:
vsf_quorum.c: In function 'logsys_subsys_init':
vsf_quorum.c:74:1: error: '__start___verbose' undeclared (first use in this function)
vsf_quorum.c:74:1: note: each undeclared identifier is reported only once for each function it appears in
vsf_quorum.c:74:1: error: '__stop___verbose' undeclared (first use in this function)
make[2]: *** [vsf_quorum.o] Error 1
make[2]: *** Waiting for unfinished jobs....
sync.c: In function 'logsys_subsys_init':
sync.c:62:1: error: '__start___verbose' undeclared (first use in this function)
sync.c:62:1: note: each undeclared identifier is reported only once for each function it appears in
sync.c:62:1: error: '__stop___verbose' undeclared (first use in this function)
vsf_ykd.c: In function 'logsys_subsys_init':
vsf_ykd.c:69:1: error: '__start___verbose' undeclared (first use in this function)
vsf_ykd.c:69:1: note: each undeclared identifier is reported only once for each function it appears in
vsf_ykd.c:69:1: error: '__stop___verbose' undeclared (first use in this function)
cfg.c: In function 'logsys_subsys_init':
cfg.c:68:1: error: '__start___verbose' undeclared (first use in this function)
cfg.c:68:1: note: each undeclared identifier is reported only once for each function it appears in
cfg.c:68:1: error: '__stop___verbose' undeclared (first use in this function)
make[2]: *** [sync.o] Error 1

Version-Release number of selected component (if applicable):
corosync-1.99.9-1.fc18

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f18 corosync-1.99.9-1.fc18.src.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=477077

Additional info:
We're building the whole distribution with koji-shadow, which uses the exact same package versions of all buildrequirements as the primary archs did. This means that one package that doesn't compile blocks a huge amount of other packages from being built. Therefore I've marked this bug as 'urgent'

Task 476183 is FAILED (build corosync-1.99.4-1.fc18)
Can't rebuild lvm2-2.02.92-1.fc18, missing 1 deps
    corosync-1.99.4-1.fc18 (broken)
Can't rebuild glibc-2.15-23.fc18, missing 1 deps
    lvm2-2.02.92-1.fc18 (brokendeps)
Can't rebuild glib2-2.31.16-2.fc18, missing 2 deps
    glibc-2.15-23.fc18 (brokendeps)
    lvm2-2.02.92-1.fc18 (brokendeps)
Can't rebuild openldap-2.4.29-3.fc18, missing 2 deps
    glibc-2.15-23.fc18 (brokendeps)
    lvm2-2.02.92-1.fc18 (brokendeps)
Can't rebuild hostname-3.11-1.fc18, missing 4 deps
    glib2-2.31.16-2.fc18 (brokendeps)
    openldap-2.4.29-3.fc18 (brokendeps)
    glibc-2.15-23.fc18 (brokendeps)
    lvm2-2.02.92-1.fc18 (brokendeps)
Can't rebuild perl-5.14.2-212.fc18, glib2-2.31.16-2.fc18 is brokendeps


....
The final count for this single build failure is:
-- top problems --
 hostname-3.11-1.fc18 (1829)
 perl-5.14.2-212.fc18 (1819)
 perl-Filter-1.43-1.fc18 (1756)
 pcre-8.30-2.fc18 (1719)
 file-5.11-1.fc18 (1719)
This means that 1829 packages are directly blocked be the corosync build failure.
Comment 1 Jan Friesse 2012-04-05 07:43:15 EDT
Angus,
__start___verbose is defined inside libqb and not Corosync, so I've reassigning this bug to you.
Comment 2 Karsten Hopp 2012-04-05 08:30:58 EDT
the build log of libqb-0.11.1-1.fc18 has
checking whether GCC supports __attribute__((section())... no

which results in
/* #undef QB_HAVE_ATTRIBUTE_SECTION */
 in include/qb/qbconfig.h



Here's the libqb-0.11.1-1.fc18 build: 
http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=76526
Comment 3 Fabio Massimo Di Nitto 2012-04-05 09:09:26 EDT
I would go one step forward and check why gcc 4.7.0 does not support __attribute__((section()) on a specific architecture.

In my experience this is generally due to some tool chain bootstrapping issues.
Comment 4 Angus Salkeld 2012-04-05 09:38:29 EDT
Created attachment 575418 [details]
chech for the section before using it

This attached corosync patch should fix the issue.
Comment 5 Jan Friesse 2012-04-05 09:54:57 EDT
Angus,
thanks for patch.

I've reassigned bug back to corosync (because it turned out to be corosync bug) and closing as nextrelease. Patch will be included in corosync 2.0 released next week.

I hope this fixed problems with PPC.

Note You need to log in before you can comment on or make changes to this bug.