Bug 810195 - need a C compiler in build requires
need a C compiler in build requires
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gpaste (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohamed El Morabity
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 06:17 EDT by cje
Modified: 2012-04-05 06:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 06:55:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cje 2012-04-05 06:17:26 EDT
i get this trying to rebuild gpaste-2.2.1-1.fc17:

configure: error: in `home/cje/rpmbuild/BUILD/gpaste-2.2.1':
configure: error: no acceptable C compiler found in $PATH

(not a high severity for me - i was just trying it out - but i don't know if this is important to other people).

cheers.
Comment 1 Mohamed El Morabity 2012-04-05 06:55:08 EDT
Thanks for your bug report.
According tot he packaging guidelines, gcc is supposed to be an implicit BuildRequires:
   http://fedoraproject.org/wiki/Packaging:Guidelines#Exceptions_2
So there's no need to set it as BuildRequires, since it's always available in our build environments (mock, koji).

By the way, I hope to make gpaste 2.5 available before the week-end.

Note You need to log in before you can comment on or make changes to this bug.