Bug 810210 - system-config-selinux - Gtk-Message: Failed to load module "pk-gtk-module"
system-config-selinux - Gtk-Message: Failed to load module "pk-gtk-module"
Status: CLOSED DUPLICATE of bug 810715
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 07:03 EDT by Flóki Pálsson
Modified: 2012-04-10 09:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-06 02:49:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flóki Pálsson 2012-04-05 07:03:47 EDT
Description of problem:
In not possible to start /usr/bin/system-config-selinux.

Version-Release number of selected component (if applicable):
policycoreutils-gui-2.1.10-29.fc17.x86_64

How reproducible:
always 

Steps to Reproduce:
1. $ /usr/bin/system-config-selinux
2. type password 
3.
  
Actual results:
[floki@F17rc3 ~]$ /usr/bin/system-config-selinux

** (process:2046): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:2046): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:2046): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
could not open interface info [/var/lib/sepolgen/interface_info]
[floki@F17rc3 ~]$ 

Expected results:
Configure SELinux in a graphical setting

Additional info:
Comment 1 Miroslav Grepl 2012-04-06 02:49:57 EDT
If you execute

$ sepolgen-ifgen

then s-c-selinux should work correctly.
Comment 2 Flóki Pálsson 2012-04-06 08:32:30 EDT
>$ sepolgen-ifgen

>then s-c-selinux should work correctly.
no.

[floki@F17rc3 ~]$ sepolgen-ifgen
could not open output file [/var/lib/sepolgen/interface_info]
[floki@F17rc3 ~]$ su  -
Password: 
[root@F17rc3 ~]# sepolgen-ifgen
error parsing headers
could not find support macros (obj_perm_sets.spt)
[root@F17rc3 ~]#

I am using fallback mode.
In /usr/share/applications selecting SELinux Management did not sem to work,
but it does now.  
It was similar fore menu item Applications -> Other -> SELinux Management.
It works now.

now
$ /usr/bin/system-config-selinux

** (process:2289): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:2289): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:2289): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
/usr/share/system-config-selinux/system-config-selinux.py:71: Warning: g_object_get_valist: object class `GnomeProgram' has no property named `default-icon'
  xml = gtk.glade.XML ("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)
WARNING: Policy would be downgraded from version 27 to 26.

and it starts
Comment 3 Flóki Pálsson 2012-04-08 11:31:37 EDT
now F17 installed from dvd 

[floki@F17rc3d ~]$  /usr/bin/system-config-selinux

** (process:4274): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:4274): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:4274): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
could not open interface info [/var/lib/sepolgen/interface_info]
[floki@F17rc3d ~]$ 

and as root 
[root@F17rc3d ~]# /usr/bin/system-config-selinux

** (process:4400): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:4400): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:4400): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
could not open interface info [/var/lib/sepolgen/interface_info]
[root@F17rc3d ~]# 

and
Comment 4 Miroslav Grepl 2012-04-10 09:19:18 EDT

*** This bug has been marked as a duplicate of bug 810715 ***

Note You need to log in before you can comment on or make changes to this bug.