Bug 810232 - Renaming system templates from web-UI isn't working
Renaming system templates from web-UI isn't working
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 08:37 EDT by James Laska
Modified: 2013-09-02 03:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 14:59:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
katello-debug-20120405083624.tar.gz (3.70 MB, application/x-gzip)
2012-04-05 08:37 EDT, James Laska
no flags Details
before_reload.png (44.76 KB, image/png)
2012-04-05 08:38 EDT, James Laska
no flags Details
after_reload.png (44.07 KB, image/png)
2012-04-05 08:38 EDT, James Laska
no flags Details
Created 4 templates originally with name like template1, template2.. (25.10 KB, image/png)
2012-04-24 01:58 EDT, Sachin Ghai
no flags Details
After renaming ( template1 to template1_rename_x86) and page reloading, the names appears correctly (21.47 KB, image/png)
2012-04-24 01:59 EDT, Sachin Ghai
no flags Details

  None (edit)
Description James Laska 2012-04-05 08:37:18 EDT
Created attachment 575390 [details]
katello-debug-20120405083624.tar.gz

Description of problem:

Using the web-ui, I rename a bunch of my system templates.  The renamed templates appear correct.

I then reload the system templates page, and some of my renamed templates have reverted to their old names.


Version-Release number of selected component (if applicable):
 * candlepin-0.5.26-1.el6.src.rpm
 * katello-0.1.307-1.el6.src.rpm
 * katello-candlepin-cert-key-pair-1.0-1.src.rpm
 * katello-certs-tools-1.0.4-1.el6.src.rpm
 * katello-cli-0.1.107-1.el6.src.rpm
 * katello-configure-0.1.107-1.el6.src.rpm
 * katello-qpid-broker-key-pair-1.0-1.src.rpm
 * katello-qpid-client-key-pair-1.0-1.src.rpm
 * katello-selinux-0.1.10-1.el6.src.rpm
 * pulp-1.0.2-1.el6.src.rpm

How reproducible:
 * I'm seeing this consistently on the same server

Steps to Reproduce:
1. Select a system template
2. Select 'Edit Details'
3. Change the template name
4. Repeat steps#1-3 for several other teampltes
   > See screenshot titled 'before_reload.png'
5. Reload the system template page
 
Actual results:

 * See screenshot titled 'after_reload.png'

Expected results:

 * See screenshot titled 'before_reload.png'

Additional info:
Comment 1 James Laska 2012-04-05 08:38:23 EDT
Created attachment 575391 [details]
before_reload.png
Comment 2 James Laska 2012-04-05 08:38:47 EDT
Created attachment 575392 [details]
after_reload.png
Comment 3 James Laska 2012-04-05 09:03:29 EDT
The following list shows what the template names are in both the Library and Dev environments.  Somehow through several renames, the arch in the 'name' got messed up.  I don't know if that's related.

katello> template list --environment Library
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
                                                                                                 Template List

 Id   Name                                           Description   Environment Id   Parent Id  
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 13   rhel-x86_64-server-6-cf-configserver           None          2                None       
 1    rhel-x86_64-server-6Server-development-tools   None          2                None       
 3    rhel-x86_64-5Server-cf-tools                   None          2                None       
 9    rhel-i386-6Server-development-tools            None          2                None       
 5    rhel-x86_64-6Server-development-tools          None          2                None       
 7    rhel-x86_64-server-6-cf-tools                  None          2                None       
 11   rhel-x86_64-server-6-development-tools         None          2                None       


katello> template list --environment Dev
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
                                                                                                 Template List

 Id   Name                                     Description   Environment Id   Parent Id  
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 14   rhel-x86_64-server-6-cf-configserver     None          3                None       
 2    rhel-i386-server-5-cf-tools              None          3                None       
 4    rhel-x86_64-server-5-cf-tools            None          3                None       
 6    rhel-i386-server-6-cf-tools              None          3                None       
 8    rhel-x86_64-server-6-cf-tools            None          3                None       
 10   rhel-i386-server-6-development-tools     None          3                None       
 12   rhel-x86_64-server-6-development-tools   None          3                None
Comment 4 James Laska 2012-04-18 09:40:52 EDT
This is easy to reproduce.  As a result, I am escalating this issue as a 1.0 release blocker.

1) Create several templates
2) Rename template1 (and the old name to the description), save and close edit
3) Rename template2 (and the old name to the description), save and close edit
4) Rename template3, notice that template3 has the description from either step#2 or step#3.

Somehow making template edits, is saving the changes to other templates.  This means we cannot trust editing system template details from the web-ui.

NOTE: This does not affect adding content to templates (packages, repos, distros) ... only editing the template name/description.
Comment 5 Brad Buckingham 2012-04-18 11:00:51 EDT
Reproduced the issue on my development environment.  What I observed was that each time the update is being submitted, it is being POST'ed to the first the first template in the list.

In my case, I created:
template1
template2
template3

I then updated
template1 to template1rename
template2 to template2rename
template3 to template3rename

In this case, the result was:
template3rename (has description of template1)
template2 (unchanged)
template3 (unchanged)
Comment 7 Brad Buckingham 2012-04-18 15:27:33 EDT
katello github commit - 80a4402057e3d6abb8cb4acd38ee8d083f2faf32
Comment 10 Sachin Ghai 2012-04-24 01:56:49 EDT
Verified with CFSE brew build : katello-0.1.311-1.el6_2.noarch

Now system template renaming from webUI is working fine. I followed the steps mentioned in comment5. 

I created 4 templates and renamed them and even reloading the 'system template' tab, the renamed templates appeared correctly with new name.
Comment 11 Sachin Ghai 2012-04-24 01:58:34 EDT
Created attachment 579756 [details]
Created 4 templates originally with name like template1, template2..
Comment 12 Sachin Ghai 2012-04-24 01:59:56 EDT
Created attachment 579757 [details]
After renaming ( template1 to template1_rename_x86) and page reloading, the names appears correctly
Comment 13 errata-xmlrpc 2012-05-15 14:59:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0665.html
Comment 14 Mike McCune 2013-08-16 14:10:23 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.