Bug 810245 - RHEL-6.1 treeinfo incorrect on cdn.rcm-qa
RHEL-6.1 treeinfo incorrect on cdn.rcm-qa
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dennis Gregorovic
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 09:06 EDT by James Laska
Modified: 2013-09-02 03:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:59:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2012-04-05 09:06:00 EDT
Using CloudForms SystemEngine, I initiated a sync from cdn.rcm-qa for RHEL6.1 and observed the following sync errors.  Is this just an old boot.iso?

There were errors syncing repository 'Red Hat Enterprise Linux 6 Serve RPMs x86_64 6.1'
 * md5_missmatch on http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.1/x86_64/os/images/boot.iso

There were errors syncing repository 'Red Hat Enterprise Linux 6 Server RPMs i386 6.1'
 * md5_missmatch on http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.1/i386/os/images/boot.iso

The file 'http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.1/i386/os/treeinfo' reports the following sha256sum:
> [checksums]
> images/boot.iso = sha256:9a4980bc273da004e2160f2e0e81f1e159b67bb8cb6783d947f5ca3574b77b19

However, the 'sha256sum' command reports ...
d7cf7e76408914f6fa4f92cc09b409fcf864d5155c694fbf1675e56c3b5a9b29  boot.iso
Comment 2 Dennis Gregorovic 2012-04-05 12:02:30 EDT
This is due to a bug 726370 in distill, which was fixed in RHEL 6.2.  The boot.iso on cdn is correct.  It's the treeinfo that is wrong.  I'm guessing you need treeinfo updated?
Comment 3 James Laska 2012-04-05 12:30:52 EDT
(In reply to comment #2)
> This is due to a bug 726370 in distill, which was fixed in RHEL 6.2.  The
> boot.iso on cdn is correct.  It's the treeinfo that is wrong.  I'm guessing you
> need treeinfo updated?

Hey Dennis, yeah ... sounds like a correct/updated treeinfo would work nicely.
Comment 4 Dennis Gregorovic 2012-04-08 20:40:59 EDT
This should be fixed now.
Comment 8 Alexander Todorov 2012-04-11 04:07:33 EDT
(In reply to comment #0)


>  * md5_missmatch on
> http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.1/x86_64/os/images/boot.iso
>

# sha256sum boot.iso 
91f1ff57787b5885561095a217eed2ef06a438a9f56a5c3aed24551b1afa06be  boot.iso

# grep boot.iso treeinfo 
boot.iso = images/boot.iso
images/boot.iso = sha256:91f1ff57787b5885561095a217eed2ef06a438a9f56a5c3aed24551b1afa06be


 
> There were errors syncing repository 'Red Hat Enterprise Linux 6 Server RPMs
> i386 6.1'
>  * md5_missmatch on
> http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.1/i386/os/images/boot.iso
> 
> The file
> 'http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.1/i386/os/treeinfo'
> reports the following sha256sum:
> > [checksums]
> > images/boot.iso = sha256:9a4980bc273da004e2160f2e0e81f1e159b67bb8cb6783d947f5ca3574b77b19
> 


# sha256sum boot.iso 
d7cf7e76408914f6fa4f92cc09b409fcf864d5155c694fbf1675e56c3b5a9b29  boot.iso

# grep boot.iso treeinfo 
boot.iso = images/boot.iso
images/boot.iso = sha256:d7cf7e76408914f6fa4f92cc09b409fcf864d5155c694fbf1675e56c3b5a9b29
Comment 9 James Laska 2012-05-03 14:06:22 EDT
This has been VERIFIED against cdn.rcm-qa.redhat.com.

However, I believe cdn.redhat.com is still broken...

> failed to sync: 
> md5_missmatch on https://cdn.redhat.com/content/dist/rhel/server/6/6.1/x86_64/os/images/boot.iso
> md5_missmatch on https://cdn.redhat.com/content/dist/rhel/server/6/6.1/i386/os/images/boot.iso
Comment 10 Dennis Gregorovic 2012-05-04 14:20:26 EDT
Please try again.  I've pushed out new treeinfo files.
Comment 12 James Laska 2012-05-11 15:15:48 EDT
(In reply to comment #10)
> Please try again.  I've pushed out new treeinfo files.

VERIFIED against cdn.redhat.com
Comment 13 errata-xmlrpc 2012-06-20 10:59:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0971.html

Note You need to log in before you can comment on or make changes to this bug.