Bug 810256 - hang of message widget
hang of message widget
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: beta
: 6.4
Assigned To: Matthew Barnes
Desktop QE
:
: 810708 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 09:23 EDT by David Jaša
Modified: 2012-04-10 02:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 810708 (view as bug list)
Environment:
Last Closed: 2012-04-06 08:10:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (32.17 KB, text/plain)
2012-04-05 09:23 EDT, David Jaša
no flags Details
e-d-s backtrace (14.24 KB, text/plain)
2012-04-05 09:41 EDT, David Jaša
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 361145 None None None Never

  None (edit)
Description David Jaša 2012-04-05 09:23:16 EDT
Description of problem:
this is a variation on fairly frequent hangs of part of main evolution window with message, this time with effectively uncancellable running option of "Ověřování zprávy" (probably "Message validation"). By uncancellable I mean that if you hit cancel button, nothing in the UI changes, the previously displayed message is still displayed and this can not be changed. After some period of time, the tree view goes grey. The only way to get evo out of this state is it's restart.

Version-Release number of selected component (if applicable):
evolution-2.28.3-24.el6.x86_64

How reproducible:
random but frequent

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Jaša 2012-04-05 09:23:47 EDT
Created attachment 575409 [details]
backtrace
Comment 2 David Jaša 2012-04-05 09:41:05 EDT
Created attachment 575420 [details]
e-d-s backtrace
Comment 3 Milan Crha 2012-04-06 08:10:57 EDT
Evolution is waiting for a response from your addressbook, based on the eds backtrace the LDAP addressbook. It does this to try whether to show images inside the HTML message or not. This is a long standing issue [1], I guess pretty known issue, and the workaround is to have Edit->Preferences->Mail Preferences->HTML Message tab, section Loading Images being set on other than "Load images only in messages from contacts". Similar is with contact photos, which is on Headers tab, at the top. You can alternatively force evolution to not search in remote addressbooks, or if you disable the LDAP addressbook from autocompletion (which is probably not feasible, as it's the main reason why you have it added - to be able to search in it when writing emails). I suggest to change the "Loading Images" and "Show the photograph of the sender" in preferences.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=361145

Thread 2 (Thread 0x7fc189c5c700 (LWP 13926)):
#0  pthread_cond_wait@@GLIBC_2.3.2 ()
#1  0x0000003a9a01098d in e_flag_wait (flag=0x250e2e0) at e-flag.c:120
#2  0x0000003aa001cd9e in do_get_contacts (sync=1, book=0x7fc17e464aa0
    [EBook], query=<value optimized out>, contacts=0x7fc189c5b4d0,
    error=0x7fc189c5b4c8, cb=<value optimized out>, closure=0x0) at
    e-book.c:2110
#3  0x0000003aa001cfcd in e_book_get_contacts (book=0x7fc17e464aa0 [EBook],
    query=0x7fc196b8de40, contacts=0x7fc189c5b4d0, error=0x7fc189c5b4c8)
    at e-book.c:2148
#4  0x00007fc1c9b0d982 in search_address_in_addressbooks (address=<value
    optimized out>, local_only=<value optimized out>, check_contact=0,
    user_data=0x0) at em-utils.c:2207
#5  0x00007fc1c9b0e2d0 in em_utils_in_addressbook (iaddr=<value optimized
    out>, local_only=0) at em-utils.c:2279
#6  0x00007fc1c9d8fed1 in emfh_gethttp (job=0x195c630, cancelled=<value
    optimized out>) at em-format-html.c:487
#7  0x00007fc1c9d90864 in efh_format_exec (m=0x7fc178c1fb20)
    at em-format-html.c:1309
#8  0x00007fc1c9b1a16f in mail_msg_proxy (msg=0x7fc178c1fb20) at mail-mt.c:522
#9  0x0000003a8806359b in g_thread_pool_thread_proxy (data=<value optimized
    out>) at gthreadpool.c:265
#10 0x0000003a88062004 in g_thread_create_proxy (data=0x233a940)
    at gthread.c:635
#11 0x0000003a87007851 in start_thread (arg=0x7fc189c5c700)
#12 0x0000003a868e767d in clone ()
Comment 4 Milan Crha 2012-04-10 02:40:05 EDT
*** Bug 810708 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.