Bug 810261 - Difficult to add a package group to a system template
Difficult to add a package group to a system template
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Eric Helms
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 09:33 EDT by James Laska
Modified: 2014-09-18 11:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When adding a package group to a system template in the System Engine web-interface, the auto-complete functionality may return multiple duplicate matches. For example, when typing "Development". System Engine will offer several matches for "Development Tools". Selecting any of the desired auto-completed matches will properly add the desired package group to the system template. This problem will be resolved in a future release of CloudForms System Engine.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 16:53:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (122.51 KB, image/png)
2012-04-05 09:33 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2012-04-05 09:33:01 EDT
Created attachment 575411 [details]
Screenshot

Description of problem:

Select a system template that has the following configuration:

> katello> template info --environment Library --name rhel-x86_64-6Server-cf-tools
> -----------------------------------------------------------------------------------------------------------
>       Template Info
> -----------------------------------------------------------------------------------------------------------
> 
> Id:                       11
> Name:                     rhel-x86_64-6Server-cf-tools
> Revision:                 9
> Description:
>     None
> Environment Id:           2
> Parent Id:                None
> Products:
>     
> Repositories:
>     Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server
>     Red Hat CloudForms Tools for RHEL 6 RPMs x86_64 6Server
>     Red Hat CloudForms Tools for RHEL 6 Beta RPMs x86_64 6Server
> Packages:
>     rhev-agent
>     open-vm-tools
>     katello-agent
>     aeolus-audrey-agent
> Parameters:
>     
> Package Groups:
>     
> Package Group Categories:

... and attempt to add a package group through the UI.  While typing, the auto-complete offers > 20 matches for 'Development Tools'.  It's not possible to tell which to select, and it should only list 1.

Version-Release number of selected component (if applicable):
 * candlepin-0.5.26-1.el6.src.rpm
 * katello-0.1.307-1.el6.src.rpm
 * katello-candlepin-cert-key-pair-1.0-1.src.rpm
 * katello-certs-tools-1.0.4-1.el6.src.rpm
 * katello-cli-0.1.107-1.el6.src.rpm
 * katello-configure-0.1.107-1.el6.src.rpm
 * katello-qpid-broker-key-pair-1.0-1.src.rpm
 * katello-qpid-client-key-pair-1.0-1.src.rpm
 * katello-selinux-0.1.10-1.el6.src.rpm
 * pulp-1.0.2-1.el6.src.rpm


How reproducible:


Steps to Reproduce:
1. Select a system template that has a single RHEL repo associated, and access to the CloudForms Tools repos (GA and Beta)
2. Select Package Groups
3. Type 'Development tools' in the search box

Actual results:

 * auto-complete lists > 20 matches for 'Development Tools'

Expected results:

 * auto-complete should list a *single* match for development tools.  There is only 1 'Development Tools' group associated with the repo assigned to this template.

Additional info:

 * See attached screenshot
Comment 1 James Laska 2012-04-18 09:15:23 EDT
Worthy of a release note for 1.0.  Requesting fix for 1.1.0 (1.0.z)
Comment 2 James Laska 2012-04-18 09:15:24 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When adding a package group to a system template in the System Engine web-interface, the auto-complete functionality may return multiple duplicate matches.  For example, when typing "Development".  System Engine will offer several matches for "Development Tools".  Selecting any of the desired auto-completed matches will properly add the desired package group to the system template.

This problem will be resolved in a future release of CloudForms System Engine.
Comment 5 Eric Helms 2013-05-13 16:53:03 EDT
System templates as a feature have been completely removed and thus closing in light of this information.
Comment 6 Mike McCune 2013-08-16 14:06:29 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.