Bug 810290 - Next Update date makes no sense
Next Update date makes no sense
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Shwetha Kallesh
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-04-05 10:29 EDT by J.C. Molet
Modified: 2012-06-20 09:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:08:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
next-update (718.07 KB, image/png)
2012-04-05 10:29 EDT, J.C. Molet
no flags Details
next-update date (115.16 KB, image/png)
2012-04-11 05:10 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description J.C. Molet 2012-04-05 10:29:15 EDT
Description of problem:
The Next update date given in the rhsm-gui doesn't seem to add up.  If I add up the frequencies of the rhsmcertd for either the autoheal or the cert refresh to the current date, I'll get a completely different date than what it says the next update will be.

Version-Release number of selected component (if applicable):
python-rhsm-0.99.7-1.git.1.e68bc91.el6.noarch
subscription-manager-gnome-0.99.12-1.git.18.188dde8.el6.x86_64
subscription-manager-0.99.12-1.git.18.188dde8.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Set your rhsmcertd to refresh on a small interval (for maximum effect)
2. Restart the service
3. Start up subscription manager
  
Actual results:
The Next Update date seems to come out of nowhere

Expected results:
The Next Update would be a combination of the last date it updated (or the current date if it never updated) plus the refresh frequency

Additional info:
see screenshot.
Comment 1 J.C. Molet 2012-04-05 10:29:44 EDT
Created attachment 575450 [details]
next-update
Comment 2 Chris Duryee 2012-04-09 15:44:35 EDT
It appears that the interval is being added as hours instead of minutes from the conf file. I'm still looking for where this is going awry though.
Comment 3 Chris Duryee 2012-04-10 11:20:13 EDT
7442a1b master 1.0.1+
Comment 5 Chris Duryee 2012-04-10 11:32:27 EDT
almost forgot the branch!

517c24d RHEL6.3 0.99.14+
Comment 6 Shwetha Kallesh 2012-04-11 05:10:15 EDT
Created attachment 576715 [details]
next-update date

verfied against

[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-1.0.0-1.git.11.f42a186.el6.x86_64
subscription-manager-migration-data-1.12.1.2-1.git.2.99d0c10.el6.noarch
subscription-manager-debuginfo-0.99.13-1.el6.x86_64
subscription-manager-migration-1.0.0-1.git.11.f42a186.el6.x86_64
subscription-manager-gnome-1.0.0-1.git.11.f42a186.el6.x86_64
subscription-manager-firstboot-1.0.0-1.git.11.f42a186.el6.x86_64


[root@dhcp201-196 ~]# cat /etc/rhsm/rhsm.conf | grep rhsmcertd -A 4
[rhsmcertd]
# Frequency of certificate refresh (in minutes):
certFrequency = 240
# Frequency of autoheal check (1440 min = 1 day):
healFrequency = 1440
Comment 8 errata-xmlrpc 2012-06-20 09:08:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.