Bug 810306 - Lack of Messaging for Skipping Subscription
Lack of Messaging for Skipping Subscription
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Shwetha Kallesh
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-04-05 11:09 EDT by Matt Reid
Modified: 2012-06-20 09:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:08:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
What a "manual config needed" screen in firstboot could look like (56.50 KB, image/png)
2012-04-05 11:09 EDT, Matt Reid
no flags Details
Manual subscription necesssary dialog (136.68 KB, image/png)
2012-04-05 11:11 EDT, Matt Reid
no flags Details
Reusable screen for firstboot "Manual Configuration Required" (121.42 KB, image/png)
2012-04-10 14:58 EDT, Michael Stead
no flags Details
manual_configuration screen (123.23 KB, image/png)
2012-04-12 10:34 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description Matt Reid 2012-04-05 11:09:14 EDT
Description of problem:
I don't think we provide enough context around manual/skipped subscription cases right now. The current button says "Skip automatic subscription selection for this system". I something along the lines of, "I would like to manually subscribe this system (takes place after firstboot)" gives them a better idea of what they're signing up for and how it works. That way if they want to manually subscribe, they know they'll have to do it after.

I'd like to see more messaging in general though, I just ran through firstboot, selected the skip checkbox, and watched the system register me, and then go straight to the user creation portion. We should either show a dialog or include an interstitial screen letting them know that they can manually subscribe after firstboot is complete. These would also be used in the case that auto-subscription fails.


Version-Release number of selected component (if applicable):
rhn-setup-1.0.0-85.el6
subscription-manager*-99.13-1.el6

How reproducible:
Always

Steps to Reproduce:
1. unregister system
2. # firstboot
3. step through firstboot, check skip subscription, click forward
4. System is registered, and then user is brought to user creation
  
Actual results:
Nothing telling them that they'll be able to subscribe manually after firstboot is done and they've booted

Expected results:
Something letting them know when/how they can subscribe manually

Additional info:
I was able to get a dialog to show during auto-subscription with the 37060.pem file. That dialog does not tell them to use the All Available Subscriptions tab, once they have launched Subscription Manager though.
Comment 1 Matt Reid 2012-04-05 11:09:58 EDT
Created attachment 575475 [details]
What a "manual config needed" screen in firstboot could look like
Comment 2 Matt Reid 2012-04-05 11:11:32 EDT
Created attachment 575476 [details]
Manual subscription necesssary dialog
Comment 6 Michael Stead 2012-04-05 14:06:54 EDT
The screen in comment 1 is only for firstboot correct?
Comment 9 Michael Stead 2012-04-10 14:57:11 EDT
There are other situations where we currently show a small dialog stating that the user should manually subscribe because of X.

1) Service Level not supported by server.
2) No installed products on system.
3) All installed products are covered by valid subscriptions.
4) Unable to subscribe to any additional products with service level: %s
5) No service levels will cover all installed products.

How do folks feel about reusing the screen in comment 1 for these situations in firstboot instead of the dialog that appears over the Create User screen. We could add a 'message' at the top, and just reiterate the text in comment 1.

There is NOT a lot of extra work involved in doing this. Pretty much adding one line per case. I would suggest we do it for 6.3.

I will also attach a screen shot.
Comment 10 Michael Stead 2012-04-10 14:58:22 EDT
Created attachment 576559 [details]
Reusable screen for firstboot "Manual Configuration Required"
Comment 11 Matt Reid 2012-04-10 15:18:55 EDT
(In reply to comment #9)
> There are other situations where we currently show a small dialog stating that
> the user should manually subscribe because of X.
> 
> 1) Service Level not supported by server.
> 2) No installed products on system.
> 3) All installed products are covered by valid subscriptions.
> 4) Unable to subscribe to any additional products with service level: %s
> 5) No service levels will cover all installed products.
> 
> How do folks feel about reusing the screen in comment 1 for these situations in
> firstboot instead of the dialog that appears over the Create User screen. We
> could add a 'message' at the top, and just reiterate the text in comment 1.
> 
> There is NOT a lot of extra work involved in doing this. Pretty much adding one
> line per case. I would suggest we do it for 6.3.
> 
> I will also attach a screen shot.

I think that's a nicer way of handling it.

Might just be compression affecting the screenshot, but it looks like the "All Available Subscriptions" isn't consistently bolded in your screenshot. All looks like it's regular.

In the future I'd like to have more messaging around which products could be satisfied/which can't/at what SLA, so users have a better idea what's getting in the way and what to look for when they're manually subscribing. I imagine that's not trivial though and will probably have to wait so we can revisit later.
Comment 12 Michael Stead 2012-04-11 08:17:46 EDT
Available in subscription-manager-0.99.14-1+, subscription-manager-1.0.0-1+

RHEL6.3: 71fa5ad9c707e40da05b4db38437aaef919d8692
master: f42a18683b52f3c2df64f7165c2170fa074551a6


NOTE: We did not have time to address the wording of the 'skip' checkbox on the
registration page. A new bug has been created to address this issue in 5.9.

BZ: 811553
Comment 14 Shwetha Kallesh 2012-04-12 10:34:43 EDT
Created attachment 577090 [details]
manual_configuration screen

Verified!!

[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-1.0.0-1.git.17.284aa0b.el6.x86_64
subscription-manager-migration-data-1.12.1.3-1.git.0.1b05607.el6.noarch
subscription-manager-migration-1.0.0-1.git.17.284aa0b.el6.x86_64
subscription-manager-debuginfo-0.99.13-1.el6.x86_64
subscription-manager-gnome-1.0.0-1.git.17.284aa0b.el6.x86_64
subscription-manager-firstboot-1.0.0-1.git.17.284aa0b.el6.x86_64
Comment 16 errata-xmlrpc 2012-06-20 09:08:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.