Bug 810350 - [ipa webui] Privilege page should not have choice to list permissions by "indirect membership"
[ipa webui] Privilege page should not have choice to list permissions by "ind...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 12:52 EDT by Namita Soman
Modified: 2012-06-20 09:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-2.2.0-9.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:26:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Namita Soman 2012-04-05 12:52:57 EDT
Description of problem:
In the Privilege page, can list Permissions. This "Shows Results" for "Direct Membership". But there is an option to list this for "Indirect Membership" also. 
There isn't a way to nest permissions, so this option is not needed.

Version-Release number of selected component (if applicable):
ipa-server-2.2.0-7.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.In WebUI, edit a Privilege
2. List Permissions
3. Can choose radiobutton - Show Results by Indirect Membership
  
Actual results:
No permissions listed

Expected results:
No permissions will be listed, so these radiobuttons are not needed. Roles tab does not have it.

Additional info:
Comment 2 Rob Crittenden 2012-04-09 13:08:21 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2611
Comment 3 Rob Crittenden 2012-04-10 15:23:09 EDT
Fixed upstream

master: e9b79cc1e111bbdc91675f8a2f48a92baa4266c9

ipa-2-2: 6b07af64926cb65695eff22b0c167eafcdf00ec4
Comment 6 Namita Soman 2012-04-16 08:19:40 EDT
Verified on ipa-server-2.2.0-9.el6.x86_64
Comment 7 Petr Vobornik 2012-04-26 09:31:58 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 9 errata-xmlrpc 2012-06-20 09:26:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.