Bug 810422 - SELinux is preventing /usr/bin/qemu-kvm from 'open' accesses on the file Fedora-17-Beta-x86_64-Live-Desktop.iso.
SELinux is preventing /usr/bin/qemu-kvm from 'open' accesses on the file Fedo...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7ccb9064a5a7f1fa9b86fd51a16...
:
: 883631 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 23:01 EDT by Germán Ríos
Modified: 2012-12-05 04:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-06 02:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Germán Ríos 2012-04-05 23:01:21 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc17.x86_64
time:           Thu 05 Apr 2012 22:01:00 COT

description:
:SELinux is preventing /usr/bin/qemu-kvm from 'open' accesses on the file Fedora-17-Beta-x86_64-Live-Desktop.iso.
:
:*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************
:
:If you want to allow confined virtual guests to read fuse files
:Then you must tell SELinux about this by enabling the 'virt_use_fusefs'boolean.
:Do
:setsebool -P virt_use_fusefs 1
:
:*****  Plugin catchall (11.6 confidence) suggests  ***************************
:
:If you believe that qemu-kvm should be allowed open access on the Fedora-17-Beta-x86_64-Live-Desktop.iso file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep qemu-kvm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:svirt_t:s0:c276,c476
:Target Context                system_u:object_r:fusefs_t:s0
:Target Objects                Fedora-17-Beta-x86_64-Live-Desktop.iso [ file ]
:Source                        qemu-kvm
:Source Path                   /usr/bin/qemu-kvm
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           qemu-system-x86-1.0-11.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-110.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc17.x86_64 #1 SMP Thu
:                              Mar 29 18:18:26 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Thu 05 Apr 2012 22:00:23 COT
:Last Seen                     Thu 05 Apr 2012 22:00:23 COT
:Local ID                      954981c5-42e1-46d5-9796-9d02a7b9ffd1
:
:Raw Audit Messages
:type=AVC msg=audit(1333681223.168:351): avc:  denied  { open } for  pid=12415 comm="qemu-kvm" name="Fedora-17-Beta-x86_64-Live-Desktop.iso" dev="sda3" ino=4906 scontext=system_u:system_r:svirt_t:s0:c276,c476 tcontext=system_u:object_r:fusefs_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1333681223.168:351): arch=x86_64 syscall=open success=no exit=EACCES a0=7f4bd66e7090 a1=81000 a2=0 a3=48 items=0 ppid=1 pid=12415 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=qemu-kvm exe=/usr/bin/qemu-kvm subj=system_u:system_r:svirt_t:s0:c276,c476 key=(null)
:
:Hash: qemu-kvm,svirt_t,fusefs_t,file,open
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-04-06 02:39:54 EDT
:*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************
:
:If you want to allow confined virtual guests to read fuse files
:Then you must tell SELinux about this by enabling the
'virt_use_fusefs'boolean.
:Do


setsebool -P virt_use_fusefs 1
Comment 2 Germán Ríos 2012-04-06 12:35:58 EDT
I have a question, if allow this, is not the default policy to treat the gnome boxes application, so make this "setsebool -P virt_use_fusefs 1" is a mandatory step to use it the app after out the box?

PD: Sorry for my horrible english, thank you in advance for your answer, and I know is a trivial step but I do not know why this is not the default

*There is not a stupid questions, only stupid like me who raise a question... I am a noob with linux :P
Comment 3 Miroslav Grepl 2012-04-10 05:39:23 EDT
The problem is a system can be setup in a variety ways. And SELinux uses booleans to cover these ways. 

And this also reason why we have setroubleshoot which should tell you how to do it using a boolean.
Comment 4 Miroslav Grepl 2012-12-05 04:38:08 EST
*** Bug 883631 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.