Bug 81046 - java application consumes all cpu resources. Receives SIGSEGV in loop
java application consumes all cpu resources. Receives SIGSEGV in loop
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-03 14:51 EST by Carsten Schulz
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-13 16:18:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carsten Schulz 2003-01-03 14:51:41 EST
Description of problem:
We are seeing a problem where a thread in our application starts consuming all
available cpu resources on the host. Our application is based on java and we are
using Sun Microsystems jre release 1.4.0_00. The problem occurs within the
java.lang.UnixProcessReaper module which runs in it's own thread and seems to
receive SIGSEGV's in a loop (I straced it's process id (it happens within
libc.o)). This is what seems to consume the cpu.

Our application is fairly simple - it collects host status info by issuing linux
commands like df etc. through java and reports the results back to a server
(tcp/ip). In parallel we have been stressing the system by executing the
Cerberus test suite.

We are providing different release of Redhat Linux precanned for our customers
based on Redhat 7.1, (7.2), 7.3 and AS2.1. Interestingly we only see this
problem on AS2.1 - not on 7.1, 7.3 (we haven't done as much testing on 7.2 as
with the other 3 releases)


Version-Release number of selected component (if applicable):
Kernel 2.4.9-e.8enterprise
glibc 2.2.4
Multiprocessor systems - 2 and 4 cpu machines (32 bit Intel)

How reproducible:
Run our client.
Run Cerberus testsuite.

Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
If you have an idea how to further debug it - it would be much appreciated we
will be able to leave a test system that is in the described state up and
running for a while.
Comment 1 Suzanne Hillman 2003-07-25 15:31:23 EDT
Does this still happen after the QU2 update, released at the end of May, which
contained the e.24 kernel?
Comment 2 Suzanne Hillman 2003-08-13 16:18:24 EDT
It's been over two weeks since I asked for more information. Thus, I am assuming
that the errata did fix the problem, and closing it. If this is not the case,
please reopen.

Note You need to log in before you can comment on or make changes to this bug.