Bug 810494 - improve error message when btrfs-progs is missing
improve error message when btrfs-progs is missing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.3
All Linux
high Severity low
: rc
: ---
Assigned To: Baoquan He
Qiao Zhao
: EasyFix, Reopened
Depends On:
Blocks: 751927 846704
  Show dependency treegraph
 
Reported: 2012-04-06 08:31 EDT by Petr Sklenar
Modified: 2013-11-21 02:55 EST (History)
3 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.0-267.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 02:55:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2012-04-06 08:31:56 EDT
Description of problem:
brtfs-progs should be in requires

Version-Release number of selected component (if applicable):

busybox-1.15.1-15.el6.i686
kexec-tools-2.0.0-236.el6.i686

How reproducible:
deterministic

Steps to Reproduce:
1. set up from bug 751927:

2. mkfs.btrfs /dev/mapper/vg_inteld3x131101-lv_home

3. rpm -e brtfs-progs

4. blkid  | grep home
/dev/mapper/vg_inteld3x131101-lv_home: UUID="1fe1a91d-6d83-41e5-858a-fedc265e7740" UUID_SUB="0651db47-5ac9-4aa2-93fc-0d42fb86ab26" TYPE="btrfs" 

5. busybox findfs UUID="1fe1a91d-6d83-41e5-858a-fedc265e7740"
/dev/dm-1

6. head /etc/kdump.conf 
btrfs /dev/mapper/vg_inteld3x131101-lv_home
default shell
core_collector makedumpfile -c -d 31

  
Actual results:
# service kdump restart
Stopping kdump:[  OK  ]
Detected change(s) the following file(s):
  
  /etc/kdump.conf
Rebuilding /boot/initrd-2.6.32-220.el6.i686kdump.img
/etc/kdump.conf: Unsupported type btrfs
Failed to run mkdumprd
Starting kdump:[FAILED]


Expected results:
it fails due to missing brtfs-progs
brtfs-progs should be in requires of kexec-tools

Additional info:
bug 751927 is blocked by this issue
Comment 12 errata-xmlrpc 2013-11-21 02:55:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1576.html

Note You need to log in before you can comment on or make changes to this bug.