Bug 810497 - v7 info - make: *** No rule to make target `kernelInfo.xml'
v7 info - make: *** No rule to make target `kernelInfo.xml'
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.5
All Linux
high Severity medium
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-04-06 08:50 EDT by Guangze Bai
Modified: 2015-02-08 16:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Makefile patch to fix test install error (737 bytes, patch)
2012-04-09 08:56 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Guangze Bai 2012-04-06 08:50:01 EDT
Description of problem:
Starting v7 info, we can see following error issued by make:

<snip>

running info on 
sh: kudzu: command not found
installing test from /usr/share/v7/tests/info into /tmp/v7-info-yuXQ5A
make: *** No rule to make target `kernelInfo.xml', needed by `install'.  Stop.
Warning: test build produced errors.
"make build" has output on stderr
make: *** No rule to make target `build'.  Stop.
Test Parameters: OUTPUTFILE=/var/log/v7/runs/1/info/output.log DEVICE= TESTSERVER=unknown RUNMODE=normal DEBUG=off UDI= 

</snip>

Version-Release number of selected component (if applicable):
v7-1.5-13

How reproducible:
always
Comment 1 Greg Nichols 2012-04-09 08:56:47 EDT
Created attachment 576209 [details]
Makefile patch to fix test install error
Comment 8 Caspar Zhang 2012-06-04 04:02:06 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 10 errata-xmlrpc 2012-06-05 17:37:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.