Bug 810516 - e-d-s sometimes segfaults without any apparent reason
e-d-s sometimes segfaults without any apparent reason
Status: CLOSED DUPLICATE of bug 608612
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: beta
: 6.4
Assigned To: Matthew Barnes
Desktop QE
abrt_hash:ccbd00bd05b9b4e5816c8d8f139...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 09:59 EDT by David Jaša
Modified: 2013-05-09 10:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-09 10:11:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (47.65 KB, text/plain)
2012-04-06 09:59 EDT, David Jaša
no flags Details
full abrt info (117.65 KB, text/plain)
2012-04-06 10:01 EDT, David Jaša
no flags Details

  None (edit)
Description David Jaša 2012-04-06 09:59:37 EDT
Created attachment 575753 [details]
backtrace

Description of problem:
e-d-s sometimes segfaults without any apparent reason

Version-Release number of selected component (if applicable):
evolution-data-server-2.28.3-15.1.el6.x86_64

How reproducible:
random

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Jaša 2012-04-06 10:01:34 EDT
Created attachment 575754 [details]
full abrt info
Comment 2 David Jaša 2012-04-06 10:03:33 EDT
A bit of clarification - 'without apparent reason' means that I don't work with evolution at all when the crash occurs.
Comment 3 Milan Crha 2012-04-10 02:36:28 EDT
Upstream bug report [1] about basically the same, but marked as fixed in 2.22.x time frame. I guess it's not completely fixed, and this one is pretty new to me. On the first look, you have configured an LDAP address book, which is notified about its view to be stopped ('view', in this case, means a particular live search, like the one used in Contacts view in Evolution itself). But apart of that I do not see what this can cause it.

Do you have any steps for this, please? Because without them it is unusable for our QA folks.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=274240
Comment 4 David Jaša 2012-04-10 04:22:58 EDT
> Do you have any steps for this, please? Because without them it is unusable for
> our QA folks.

Unfortunately, I do not. This happened when evo was idle at some other virtual desktop and abrt just said that e-d-s crashed...
Comment 5 Milan Crha 2012-04-11 02:36:06 EDT
I'm afraid there is not much to be done here then. With evo in idle, maybe it was updating your account with new messages, and in Edit->Preferences->Mail Preferences->tab Junk you've set to check for junk and to not mark message as junk if the person is in your addressbook? That would explain the addressbook lookup when you were not doing anything with evolution itself.
Comment 6 David Jaša 2012-04-11 06:08:01 EDT
In this case, I've got disabled both check for mail junkiness itself and any interaction with addressbook...
Comment 9 RHEL Product and Program Management 2012-07-10 02:35:22 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2012-07-10 19:10:12 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 11 RHEL Product and Program Management 2012-12-14 02:07:57 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 12 Milan Crha 2013-05-09 10:11:29 EDT

*** This bug has been marked as a duplicate of bug 608612 ***

Note You need to log in before you can comment on or make changes to this bug.