Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 810537 - Running [Manual Autodiscovery] operation fails
Summary: Running [Manual Autodiscovery] operation fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RHQ Project
Classification: Other
Component: Agent
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-06 15:01 UTC by Libor Zoubek
Modified: 2015-11-02 00:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-10 10:23:58 UTC


Attachments (Terms of Use)
RHQ server log (610.44 KB, application/octet-stream)
2012-04-06 15:01 UTC, Libor Zoubek
no flags Details

Description Libor Zoubek 2012-04-06 15:01:46 UTC
Created attachment 575786 [details]
RHQ server log

Description of problem: I am getting ugly error when I try to run Manual discovery or other operations using UI.

Version-Release number of selected component (if applicable):
Version: 4.4.0-SNAPSHOT
Build Number: 61e6421

How reproducible: not sure

Steps to Reproduce:
1. setup 2 agents, 1 on localhost and 2nd on remote
2. import both platforms with all children
3. run Manual Audodiscovery operation using UI on local platform
  
Actual results:

org.rhq.core.clientapi.agent.PluginContainerException: Failed to submit invocation request. resource=[10001], operation=[discovery], jobId=[rhq-resource-10001--121207376-1333721908447_=_rhq-resource-10001_=_1333721926665]

Expected results: manual autodiscovery is successfull


Additional info: If I try to run 'Manual Autodiscovery' again, it take quite a long time (10 minutes) still unable to finish. In the meantime I can successfully run autodiscovery on remote agent without any problem.

In attached log I tried to uninventory both platforms while autodiscovery on local agent was still running

Currently above steps to reproduce are not 100% I am trying to find out more specific conditions to reproduce this BZ, but I hope server log could help devs figure out..

Comment 1 Charles Crouch 2012-04-09 14:32:47 UTC
Libor do you still have the agent.log handy? With any bugs that deal with some sort of action that ultimately ends up on the agent side, a debug agent log as well as server side logs are very helpful. Thanks

Comment 2 Jay Shaughnessy 2012-04-09 17:36:28 UTC

A manual autoudiscovery operation worked for me but I didn't follow all of
the repro steps. Just tried it on my one (win) platform.  I don't think 
the issue here has to do with multiple platforms unless somehow the wrong
agent was sent the request.

The error is on the agent, which can't find the resource container for
resource 10001.  Is the 10001 platform resource the one that processed
the operation?

Comment 3 Libor Zoubek 2012-04-10 10:23:58 UTC
Charles, 

unfortunately I do not have agent.log anymore. I am sorry.

Anyway I cannot reproduce this BZ anymore. I reproduced it twice (in a row) on my automation, which always runs on latest master build.

Jay, yes, 10001 was the platform being operation invoked on.

I am closing, since this is not a bug anymore


Note You need to log in before you can comment on or make changes to this bug.