Bug 810552 - Eclipse 4.2 doesn't work with jsch < 1.46 (add Requires: jsch >= 1.46)
Eclipse 4.2 doesn't work with jsch < 1.46 (add Requires: jsch >= 1.46)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 12:06 EDT by Severin Gehwolf
Modified: 2014-01-12 19:26 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-06 13:14:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2012-04-06 12:06:47 EDT
Description of problem:
Eclipse fails to resolve the CVS plug-in, which in turn is caused by not being able to resolve the jsch dependency.

Version-Release number of selected component (if applicable):
rpm -q eclipse-platform
eclipse-platform-4.2.0-0.5.fa15ab.fc18.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install jsch 1.45 from F16
2. rm -rf ~/.eclipse
3. yum erase \*eclipse\*
4. yum install --enablerepo=rawhide eclipse-pde
5. Start eclipse, observe that only Debug, Resource perspectives are available (no Java/PDE perspectives) 
  
Actual results:
Eclipse isn't able to resolve the CVS plug-in properly.

Expected results:
All bundles up to eclipse-pde are properly resolved.

Additional info:
I'm on a F16 host with eclipse installed from rawhide. An explicit BR/R pair for jsch 1.46 should fix this problem.
Comment 1 Krzysztof Daniel 2012-04-06 12:16:20 EDT
Fix for this should be ready today. Note that 1.46 is not enough, because jsch manifest was properly updated in second release.
Comment 2 Severin Gehwolf 2012-04-06 12:33:06 EDT
Awesome, thanks!

Note You need to log in before you can comment on or make changes to this bug.