Bug 810562 - Function keys for lcd brightness and wireless does not work on HP Folio 13 laptop
Function keys for lcd brightness and wireless does not work on HP Folio 13 la...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.2
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 13:41 EDT by Alexander Lindqvist
Modified: 2012-06-07 09:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 09:03:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg (39.99 KB, application/octet-stream)
2012-04-06 13:41 EDT, Alexander Lindqvist
no flags Details
lspci -vvv (30.22 KB, text/plain)
2012-04-06 13:42 EDT, Alexander Lindqvist
no flags Details

  None (edit)
Description Alexander Lindqvist 2012-04-06 13:41:44 EDT
Created attachment 575812 [details]
Dmesg

Description of problem:
FN+F2+F3 keys for changing LCD brightness does not work.
FN+F12 (enable/disable Intel Centrino 1030 Wireless/bluetooth combo card) does
not work.
Switching "actions keys mode" to disable in BIOS (so that you have to use the
fn key + other key as usual) does not help.

xev reports nothing when pressing these keys. Other actions keys like for the
led backlit keyboard works)

Version-Release number of selected component (if applicable):
2.6.32-220.7.1.el6.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Unable to enable wireless (hardware disabled)
Unable to adjust lcd brightness via action keys

Expected results:
Adjusting LCD brightness via fn+f2/f3 keys should work.
Enable/disable wireless should work.

Additional info:
The problem exist in Fedora 17 aswell and bug has been filed here: https://bugzilla.redhat.com/show_bug.cgi?id=810409
Comment 1 Alexander Lindqvist 2012-04-06 13:42:25 EDT
Created attachment 575813 [details]
lspci -vvv
Comment 2 Alexander Lindqvist 2012-04-06 13:56:13 EDT
acpi_listen does not output anything on these keys.
Comment 4 RHEL Product and Program Management 2012-05-03 01:16:21 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 Prarit Bhargava 2012-06-07 09:03:41 EDT
This laptop is not supported in RHEL.  Please see http://www.redhat.com/hardware for supported hardware.

Thanks,

P.

Note You need to log in before you can comment on or make changes to this bug.