Bug 810570 - crash in convert: magick/quantum.c:215: DestroyQuantumInfo
crash in convert: magick/quantum.c:215: DestroyQuantumInfo
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ImageMagick (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jan Horak
Desktop QE
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 14:35 EDT by Karel Volný
Modified: 2015-07-22 03:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 03:03:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2012-04-06 14:35:13 EDT
Description of problem:
The test /CoreOS/ImageMagick/convert-images fails - convert coredumps in two cases which seem to share the same cause.


Version-Release number of selected component (if applicable):
ImageMagick-6.5.4.7-5.el6


How reproducible:
always


Steps to Reproduce:
1. run the test /CoreOS/ImageMagick/convert-images
  

Actual results:
Processing 'testcase.02.tif' file -----
testcase.02.tif: TIFF image data, little-endian
convert: magick/quantum.c:215: DestroyQuantumInfo: Assertion `quantum_info->signature == 0xabacadabUL' failed.
./runtest.sh: line 47: 18543 Aborted (core dumped) convert $i out.png 2>&1
18544 Done | tee -a $OUTPUTFILE
# Command 'convert testcase.02.tif out.png' returned 134 (should be >= 0 && <= 127)
# Listing core-dumps:
ls: cannot access core*: No such file or directory
ERROR: convert failed for 'testcase.02.tif'

----- Processing 'testcase.07.tif' file -----
testcase.07.tif: TIFF image data, little-endian
convert: magick/quantum.c:215: DestroyQuantumInfo: Assertion `quantum_info->signature == 0xabacadabUL' failed.
./runtest.sh: line 47: 18969 Aborted (core dumped) convert $i out.png 2>&1
18970 Done | tee -a $OUTPUTFILE
# Command 'convert testcase.07.tif out.png' returned 134 (should be >= 0 && <= 127)
# Listing core-dumps:
ls: cannot access core*: No such file or directory
ERROR: convert failed for 'testcase.07.tif'


Expected results:
(no abort)


Additional info:
Comment 3 RHEL Product and Program Management 2012-07-10 02:28:31 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 19:24:29 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 RHEL Product and Program Management 2012-09-07 01:18:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 13 errata-xmlrpc 2015-07-22 03:03:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1359.html

Note You need to log in before you can comment on or make changes to this bug.