Bug 810616 - [HP Elitebook 8460p] Pressing Fn+Brightness control keys has no effect
[HP Elitebook 8460p] Pressing Fn+Brightness control keys has no effect
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
first=3.3.0 hotkeys brightness
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-07 04:59 EDT by Tadej Janež
Modified: 2013-03-14 14:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 14:13:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tadej Janež 2012-04-07 04:59:28 EDT
Description of problem:
I was performing the Fedora 17 Power Management test day, more specifically, the Backlight control test:
https://fedoraproject.org/wiki/QA:Testcase_Power_Management_Backlight_Control.
I was trying to use the laptop's Fn + Brightness up/down keys to change brightness but it had no effect.

I'm filing this against the kernel, but I'm not sure what is at fault here. Brightness control works with the same LiveUSB on another laptop, so I'm usuming it is the kernel not handling the Fn+Brightness keys.

Version-Release number of selected component (if applicable):
kernel-3.3.0-1.fc17.x86_64

How reproducible:
Always
Comment 1 David Paschal 2012-07-30 18:53:22 EDT
http://www.linlap.com/wiki/hp+elitebook+8460p has some relevant info that could lead to a fix for this bug.
Comment 2 Britton Dodd 2012-09-10 21:08:47 EDT
Still relevant as of Kernel 3.5.3-1. I'm going to try to compile a kernel with these patches for F17 and see if the issue is resolved. I believe this is a patch for the radeon OSS driver which I believe is a kmod or kernel built-in option.
Comment 3 Josh Boyer 2013-03-14 14:13:01 EDT
The patches referenced in comment #1 went into the 3.7 kernel.  If you're still having issues with 3.8.2 in updates-testing, please reopen.

Note You need to log in before you can comment on or make changes to this bug.