Bug 810617 - TypeError: window_set_default_icon() argument 1 must be gtk.gdk.Pixbuf, not None
TypeError: window_set_default_icon() argument 1 must be gtk.gdk.Pixbuf, not None
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:075344093b9d8543188bdc74f63...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-07 05:04 EDT by John Chandler
Modified: 2012-04-09 03:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-08 11:11:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-NedHzo (211.27 KB, text/plain)
2012-04-07 05:04 EDT, John Chandler
no flags Details

  None (edit)
Description John Chandler 2012-04-07 05:04:14 EDT
libreport version: 2.0.6
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-7.fc16.x86_64
product:        Fedora
reason:         TypeError: window_set_default_icon() argument 1 must be gtk.gdk.Pixbuf, not None
time:           Sat Apr  7 05:00:19 2012
version:        16

anaconda-tb-NedHzo: Text file, 216338 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.25 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1409, in setup_window
:    gtk.window_set_default_icon(pixbuf)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1426, in run
:    self.setup_window(False)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1169, in run
:    self.icw.run()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 319, in run
:    self.anaconda.intf.run(self.anaconda)
:  File "/usr/sbin/anaconda", line 770, in <module>
:    anaconda.dispatch.run()
:TypeError: window_set_default_icon() argument 1 must be gtk.gdk.Pixbuf, not None
Comment 1 John Chandler 2012-04-07 05:04:23 EDT
Created attachment 575891 [details]
File: anaconda-tb-NedHzo
Comment 2 John Chandler 2012-04-07 05:09:42 EDT
This is using the Fedora 16 Live CD's install to hard drive option on a 2008 Intel Mac Mini. Installation fails immediately, message above is the only thing that shows.

OS X Snow Leopard and Debian install fine on system (I just checked, though I only want to run Fedora on the system). Debian installation refuses to boot, but I know that's a known and separate issue.
Comment 3 Chris Lumens 2012-04-08 11:11:10 EDT
You've got squashfs errors at the end of your syslog, indicating errors reading the media.  This could be due to a bad download, bad burn, driver failure, or hardware failure.
Comment 4 John Chandler 2012-04-09 03:16:42 EDT
Doh! I should've spotted that. Thanks Chris!

Note You need to log in before you can comment on or make changes to this bug.