Bug 810642 - Runfield demo is getting stuck, WebKit works
Runfield demo is getting stuck, WebKit works
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-07 11:26 EDT by Jan Kratochvil
Modified: 2012-05-03 07:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: firefox-12.0-1.fc16.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 03:30:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2012-04-07 11:26:11 EDT
Description of problem:
Found JavaScript Runfield demo - it works great in WebKit but it is not playable in Firefox.

Version-Release number of selected component (if applicable):
firefox-11.0-1.fc16.x86_64
xulrunner-11.0-3.fc16.x86_64

How reproducible:
Always.

Steps to Reproduce:
http://www.mozilla.org/en-US/firefox/features/
->
http://mozillademos.org/demos/runfield/demo.html
Jump over holes.

Actual results:
On almost each jump it gets stuck for about 0.5sec, the game is not playable.

Expected results:
Normal playable game like in:
epiphany-3.2.1-3.fc16.x86_64
webkitgtk3-1.6.1-1.fc16.x86_64

Additional info:
xorg-x11-server-Xorg-1.11.4-3.fc16.x86_64
xorg-x11-drv-intel-2.17.0-8.fc16.x86_64
00:02.0 0300: 8086:0126 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
Comment 1 Jan Horak 2012-04-10 07:02:22 EDT
I can reproduce. This seems to be related to sound. If I turn sound/music off I don't see this problem anymore.
Comment 2 Jan Kratochvil 2012-04-17 17:36:33 EDT
Much better visible is WebKit<->Gecko slowness in another HTML5 game:
http://www.adityaravishankar.com/projects/games/command-and-conquer/
Comment 3 Jan Horak 2012-04-25 10:33:00 EDT
Upstream bug: https://bugzilla.mozilla.org/show_bug.cgi?id=743972
Comment 4 Jan Kratochvil 2012-04-30 03:30:12 EDT
Maybe it is not yet perfect but with Firefox 12 the major performance issue is gone, the Comment 2 demo also works fine now.
Comment 5 Jan Horak 2012-05-03 07:57:07 EDT
Okay, I can see significant improvement too. I think we can close it as current release. Feel free to reopen if reoccurs.

Note You need to log in before you can comment on or make changes to this bug.