Bug 810662 - software rendering by default on HD 5770 despite Xorg.0.log claiming otherwise
software rendering by default on HD 5770 despite Xorg.0.log claiming otherwise
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-07 17:18 EDT by Stijn Hoop
Modified: 2012-04-09 15:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 15:36:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (56.04 KB, text/x-log)
2012-04-07 17:18 EDT, Stijn Hoop
no flags Details
glxinfo (19.68 KB, text/plain)
2012-04-07 17:18 EDT, Stijn Hoop
no flags Details
env LIBGL_DEBUG=verbose glxinfo |& tee glxinfo-debug.out (20.00 KB, application/octet-stream)
2012-04-09 14:59 EDT, Stijn Hoop
no flags Details

  None (edit)
Description Stijn Hoop 2012-04-07 17:18:30 EDT
Created attachment 575969 [details]
Xorg.0.log

Description of problem:

After a yum upgrade (!) of F16 to F17 from today (2012-04-07) gnome-shell started using excessive CPU time (150% of my quadcore AMD while moving a window).

I suspected software rendering was enabled so I tried to verify using Xorg.0.log and glxinfo. However I get conflicting information: glxinfo says that I'm running "Gallium 0.4 on llvmpipe", with "vmware" as the vendor. However this is most assuredly a physical box. Xorg.0.log claims that DRI is provided by r600. Please find both glxinfo as well as Xorg.0.log attached.

I tried to force r600 DRI by moving both /usr/lib64/dri/swrast_dri.so and /usr/lib64/dri/vmwgfx_dri.so out of the way but without those libraries GDM could not show a login window. Interestingly X did appear to start and I could move the mouse, but that was it.

[stijn@tangaloor] <~> rpm -q mesa-dri-drivers xorg-x11-drv-ati
mesa-dri-drivers-8.0.2-2.fc17.x86_64
xorg-x11-drv-ati-6.14.4-2.20120329gitde2419e55.fc17.x86_64
Comment 1 Stijn Hoop 2012-04-07 17:18:58 EDT
Created attachment 575970 [details]
glxinfo
Comment 2 Adam Jackson 2012-04-09 13:31:14 EDT
Please attach the output from:

$ LIBGL_DEBUG=verbose glxinfo
Comment 3 Stijn Hoop 2012-04-09 14:59:32 EDT
Created attachment 576284 [details]
env LIBGL_DEBUG=verbose glxinfo |& tee glxinfo-debug.out

Not sure whether this is what you mean but the error output is interesting. Where is my drm device and how can I check the permissions?
Comment 4 Stijn Hoop 2012-04-09 15:08:53 EDT
OK, some Googling cleared that up:

$ ls -l /dev/dri 
total 0K
crw-rw----. 1 root video 226,  0 Apr  9 20:55 card0
crw-------. 1 root video 226, 64 Apr  9 20:55 controlD64

$ sudo usermod -a -G video stijn

<logout/login>

$ glxinfo | grep -i renderer
OpenGL renderer string: Gallium 0.4 on AMD JUNIPER

Not entirely sure why I needed to add myself though, but it's not mesa at fault. I'll go poke at stuff like ConsoleKit I guess?
Comment 5 Stijn Hoop 2012-04-09 15:36:40 EDT
Booting a Live USB results in the correct behaviour from the start. Closing this as it seems most likely that my yum upgrade botched something and I doubt it's worth the time to track this down. I'll simply reinstall from Beta RC3.

Note You need to log in before you can comment on or make changes to this bug.