Bug 810686 - RFE: Support for Intel Cedarview (DRM_GMA3600)
RFE: Support for Intel Cedarview (DRM_GMA3600)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-08 06:20 EDT by Vladimir Rusinov
Modified: 2012-04-28 20:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: kernel-3.3.4-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-28 20:58:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Rusinov 2012-04-08 06:20:55 EDT
Description of problem:

I've got new MSI netbook with Intel Atom N2800 and out of the box graphics works only with vesa at 800x600 (while my netbook is capable of 1024x800 or so).

lspci reports card as "Intel Corporation Cedarview Intergared Graphics Controller (rev 09)".

OS: Fedoda 17 Beta RC3

Kernel version: 3.3.1-3.fc17

It seems this is due to CONFIG_DRM_GMA600 and/or CONFIG_DRM_GMA3600 are missing from kernel config.
Comment 1 Vladimir Rusinov 2012-04-09 07:45:10 EDT
Yep, it's running in its native resolution on .local kernel with CONFIG_DRM_GMA600=y and CONFIG_DRM_GMA3600=y.

No side effects so far, but I've not tested it for a long time / on another hardware.
Comment 2 Josh Boyer 2012-04-09 09:36:20 EDT
(In reply to comment #1)
> Yep, it's running in its native resolution on .local kernel with
> CONFIG_DRM_GMA600=y and CONFIG_DRM_GMA3600=y.
> 
> No side effects so far, but I've not tested it for a long time / on another
> hardware.

You probably only need CONFIG_DRM_GMA3600=m set, right?
Comment 3 Vladimir Rusinov 2012-04-09 13:27:14 EDT
Yes, according to description is should be enough to have GMA3600.

But it's not separate module, it's just adds support to gma500_gfx module, so it's y/n option.
Comment 4 Josh Boyer 2012-04-23 13:16:44 EDT
I've enabled this in F17/rawhide now.  Will be in the next build.
Comment 5 Vladimir Rusinov 2012-04-26 02:59:25 EDT
Thanks. Works good with 3.4.0-0.rc4.git1.1.fc18.x86_64 from rawhide on F17.

Suspend/hibernate does not work (screen is bland after wakeup), but this is another bug.
Comment 6 Fedora Update System 2012-04-27 19:05:38 EDT
kernel-3.3.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.4-1.fc17
Comment 7 Fedora Update System 2012-04-28 13:12:05 EDT
Package kernel-3.3.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.4-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6898/kernel-3.3.4-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-04-28 20:58:15 EDT
kernel-3.3.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.