Bug 810715 - selinux-polgengui - WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'
selinux-polgengui - WARNING **: Trying to register gtype 'GMountMountFlags' a...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
: 810210 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-08 11:49 EDT by Flóki Pálsson
Modified: 2012-04-25 07:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 16:37:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
selinux-polgengui - same error (3.33 KB, text/plain)
2012-04-12 05:22 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2012-04-08 11:49:26 EDT
Description of problem:
'Generate SELinux policy modules' can not start. Not from terminal ( user and root). In can not sart from menu ( falback mode ) or from icon in /usr/share/applications.

Version-Release number of selected component (if applicable):
policycoreutils-gui-2.1.10-29.fc17.x86_64


How reproducible:


Steps to Reproduce:
1. in terminal /usr/bin/selinux-polgengui
2.
3.
  
Actual results:
$ /usr/bin/selinux-polgengui

** (process:4480): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:4480): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:4480): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
could not open interface info [/var/lib/sepolgen/interface_info]
[floki@F17rc3d ~]$ 

Expected results:
Application 
Generate SELinux policy modules

Additional info:
Bug 810210  looks similar

as root 
"
[root@F17rc3d ~]# /usr/bin/selinux-polgengui

** (process:4484): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:4484): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:4484): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
could not open interface info [/var/lib/sepolgen/interface_info]
[root@F17rc3d ~]# 
"
Comment 1 Miroslav Grepl 2012-04-10 09:19:18 EDT
*** Bug 810210 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-04-10 09:22:55 EDT
Ok, could you try to execute

$ yum reinstall selinux-policy-targeted
Comment 3 Flóki Pálsson 2012-04-12 05:22:55 EDT
Created attachment 577011 [details]
selinux-polgengui - same error

>Ok, could you try to execute

>$ yum reinstall selinux-policy-targeted

same error.   See athachment
Comment 4 Daniel Walsh 2012-04-13 16:22:08 EDT
Sorry you have to run sepolgen as root.
Comment 5 Flóki Pálsson 2012-04-13 17:36:31 EDT
[root@F17rc4 ~]# sepolgen
could not open interface info [/var/lib/sepolgen/interface_info]
[root@F17rc4 ~]# 

and 
from 
/usr/share/application

SELinux Management 'Configure SELinux in a graphical setting'  can not start 
and 
SELinux Policy Generation Tool 'SELinux Policy Generation Tool' can not start

and not from menu.
I am using fallback mode
Comment 6 Flóki Pálsson 2012-04-13 18:04:52 EDT
This was installed from rc4   Fedora-17-Beta-x86_64-DVD.iso using Icelandic as language. 
Changing  language with system settings to British English did not help.
Changing to English did help.
Then changing back to British English and  Icelandic is ok.
Now it works.
Comment 7 Daniel Walsh 2012-04-16 14:41:40 EDT
sepolgen-ifgen
Comment 8 Flóki Pálsson 2012-04-24 20:00:06 EDT
$ sepolgen-ifgen
could not open output file [/var/lib/sepolgen/interface_info]
[floki@F17rc4 ~]$
Comment 9 Flóki Pálsson 2012-04-24 20:04:03 EDT
as root nothing happens.
Comment 10 Miroslav Grepl 2012-04-25 07:17:18 EDT
(In reply to comment #9)
> as root nothing happens.

so does it work for you now?

Note You need to log in before you can comment on or make changes to this bug.