Bug 810729 - SELinux is preventing /bin/rpm from 'read' accesses on the chr_file urandom.
SELinux is preventing /bin/rpm from 'read' accesses on the chr_file urandom.
Status: CLOSED DUPLICATE of bug 810731
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:af5920b5781530fddb2d75f0c92...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-08 14:02 EDT by Renich Bon Ciric
Modified: 2012-04-09 14:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 14:48:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Renich Bon Ciric 2012-04-08 14:02:56 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.1-2.fc16.x86_64
reason:         SELinux is preventing /bin/rpm from 'read' accesses on the chr_file urandom.
time:           Sun 08 Apr 2012 01:02:40 PM CDT

description:
:SELinux is preventing /bin/rpm from 'read' accesses on the chr_file urandom.
:
:*****  Plugin catchall_boolean (47.5 confidence) suggests  *******************
:
:If you want to allow users to login using a sssd server
:Then you must tell SELinux about this by enabling the 'authlogin_nsswitch_use_ldap'boolean.
:Do
:setsebool -P authlogin_nsswitch_use_ldap 1
:
:*****  Plugin catchall_boolean (47.5 confidence) suggests  *******************
:
:If you want to enable reading of urandom for all domains.
:Then you must tell SELinux about this by enabling the 'global_ssp'boolean.
:Do
:setsebool -P global_ssp 1
:
:*****  Plugin catchall (6.38 confidence) suggests  ***************************
:
:If you believe that rpm should be allowed read access on the urandom chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rpm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:vhostmd_t:s0
:Target Context                system_u:object_r:urandom_device_t:s0
:Target Objects                urandom [ chr_file ]
:Source                        rpm
:Source Path                   /bin/rpm
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           vhostmd-0.4-12.fc15.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.1-2.fc16.x86_64 #1 SMP
:                              Tue Apr 3 00:46:10 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    Sun 08 Apr 2012 01:34:06 AM CDT
:Last Seen                     Sun 08 Apr 2012 12:48:00 PM CDT
:Local ID                      66060f1d-fc90-47fa-83ab-ff6179185255
:
:Raw Audit Messages
:type=AVC msg=audit(1333907280.999:112): avc:  denied  { read } for  pid=1948 comm="vhostmd" name="urandom" dev="devtmpfs" ino=7175 scontext=system_u:system_r:vhostmd_t:s0 tcontext=system_u:object_r:urandom_device_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1333907280.999:112): arch=x86_64 syscall=access success=no exit=EACCES a0=361bc69970 a1=4 a2=0 a3=0 items=0 ppid=1 pid=1948 auid=4294967295 uid=112 gid=112 euid=112 suid=112 fsuid=112 egid=112 sgid=112 fsgid=112 tty=(none) ses=4294967295 comm=vhostmd exe=/usr/sbin/vhostmd subj=system_u:system_r:vhostmd_t:s0 key=(null)
:
:Hash: rpm,vhostmd_t,urandom_device_t,chr_file,read
:
:audit2allow
:
:#============= vhostmd_t ==============
:#!!!! This avc can be allowed using one of the these booleans:
:#     authlogin_nsswitch_use_ldap, global_ssp
:
:allow vhostmd_t urandom_device_t:chr_file read;
:
:audit2allow -R
:
:#============= vhostmd_t ==============
:#!!!! This avc can be allowed using one of the these booleans:
:#     authlogin_nsswitch_use_ldap, global_ssp
:
:allow vhostmd_t urandom_device_t:chr_file read;
:
Comment 1 Daniel Walsh 2012-04-09 14:48:06 EDT

*** This bug has been marked as a duplicate of bug 810731 ***

Note You need to log in before you can comment on or make changes to this bug.