Bug 810730 - SELinux is preventing /bin/netstat from 'search' accesses on the directory net.
SELinux is preventing /bin/netstat from 'search' accesses on the directory net.
Status: CLOSED DUPLICATE of bug 810731
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f4d6ae862b9412d312f258dd3e6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-08 14:03 EDT by Renich Bon Ciric
Modified: 2012-04-09 14:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 14:48:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Renich Bon Ciric 2012-04-08 14:03:27 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.1-2.fc16.x86_64
reason:         SELinux is preventing /bin/netstat from 'search' accesses on the directory net.
time:           Sun 08 Apr 2012 01:03:16 PM CDT

description:
:SELinux is preventing /bin/netstat from 'search' accesses on the directory net.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that netstat should be allowed search access on the net directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep netstat /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:vhostmd_t:s0
:Target Context                system_u:object_r:sysctl_net_t:s0
:Target Objects                net [ dir ]
:Source                        netstat
:Source Path                   /bin/netstat
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           net-tools-1.60-126.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.1-2.fc16.x86_64 #1 SMP
:                              Tue Apr 3 00:46:10 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Sun 08 Apr 2012 01:34:06 AM CDT
:Last Seen                     Sun 08 Apr 2012 12:48:00 PM CDT
:Local ID                      126a94b9-7a6e-4576-90e5-6f8f603a3be6
:
:Raw Audit Messages
:type=AVC msg=audit(1333907280.739:111): avc:  denied  { search } for  pid=2140 comm="netstat" name="net" dev="proc" ino=13516 scontext=system_u:system_r:vhostmd_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1333907280.739:111): arch=x86_64 syscall=access success=no exit=EACCES a0=4170c1 a1=4 a2=d a3=0 items=0 ppid=2136 pid=2140 auid=4294967295 uid=112 gid=112 euid=112 suid=112 fsuid=112 egid=112 sgid=112 fsgid=112 tty=(none) ses=4294967295 comm=netstat exe=/bin/netstat subj=system_u:system_r:vhostmd_t:s0 key=(null)
:
:Hash: netstat,vhostmd_t,sysctl_net_t,dir,search
:
:audit2allow
:
:#============= vhostmd_t ==============
:allow vhostmd_t sysctl_net_t:dir search;
:
:audit2allow -R
:
:#============= vhostmd_t ==============
:allow vhostmd_t sysctl_net_t:dir search;
:
Comment 1 Daniel Walsh 2012-04-09 14:48:28 EDT

*** This bug has been marked as a duplicate of bug 810731 ***

Note You need to log in before you can comment on or make changes to this bug.