Bug 810732 - SELinux is preventing /bin/rpm from 'getattr' accesses on the directory /etc/lvm.
SELinux is preventing /bin/rpm from 'getattr' accesses on the directory /etc/...
Status: CLOSED DUPLICATE of bug 810731
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5d74289b7dc7f699f418f3a2acc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-08 14:04 EDT by Renich Bon Ciric
Modified: 2012-04-09 14:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 14:44:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Renich Bon Ciric 2012-04-08 14:04:25 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.1-2.fc16.x86_64
reason:         SELinux is preventing /bin/rpm from 'getattr' accesses on the directory /etc/lvm.
time:           Sun 08 Apr 2012 01:04:16 PM CDT

description:
:SELinux is preventing /bin/rpm from 'getattr' accesses on the directory /etc/lvm.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rpm should be allowed getattr access on the lvm directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rpm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:vhostmd_t:s0
:Target Context                system_u:object_r:lvm_etc_t:s0
:Target Objects                /etc/lvm [ dir ]
:Source                        rpm
:Source Path                   /bin/rpm
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           rpm-4.9.1.2-6.fc16.x86_64
:Target RPM Packages           lvm2-2.02.86-6.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.1-2.fc16.x86_64 #1 SMP
:                              Tue Apr 3 00:46:10 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    Sun 08 Apr 2012 01:34:06 AM CDT
:Last Seen                     Sun 08 Apr 2012 12:48:00 PM CDT
:Local ID                      b87ab4ad-3ef5-406b-8605-dac59d939cad
:
:Raw Audit Messages
:type=AVC msg=audit(1333907280.735:108): avc:  denied  { getattr } for  pid=2136 comm="rpm" path="/etc/lvm" dev="dm-1" ino=2491308 scontext=system_u:system_r:vhostmd_t:s0 tcontext=system_u:object_r:lvm_etc_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1333907280.735:108): arch=x86_64 syscall=stat success=no exit=EACCES a0=7fff2a1fcba0 a1=7fff2a1fcb10 a2=7fff2a1fcb10 a3=796c68746e6f6d items=0 ppid=2135 pid=2136 auid=4294967295 uid=112 gid=112 euid=112 suid=112 fsuid=112 egid=112 sgid=112 fsgid=112 tty=(none) ses=4294967295 comm=rpm exe=/bin/rpm subj=system_u:system_r:vhostmd_t:s0 key=(null)
:
:Hash: rpm,vhostmd_t,lvm_etc_t,dir,getattr
:
:audit2allow
:
:#============= vhostmd_t ==============
:allow vhostmd_t lvm_etc_t:dir getattr;
:
:audit2allow -R
:
:#============= vhostmd_t ==============
:allow vhostmd_t lvm_etc_t:dir getattr;
:
Comment 1 Daniel Walsh 2012-04-09 14:44:17 EDT

*** This bug has been marked as a duplicate of bug 810731 ***

Note You need to log in before you can comment on or make changes to this bug.