Bug 810750 - The perl-HTTP-Proxy depends on perl(CGI::Util)
The perl-HTTP-Proxy depends on perl(CGI::Util)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-HTTP-Proxy (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-08 18:45 EDT by Emmanuel Seyman
Modified: 2012-04-12 14:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 14:02:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Seyman 2012-04-08 18:45:59 EDT
Description of problem:
The perl-HTTP-Proxy depends on perl(CGI::Util) which forces the user to include a number of useless perl modules (I'm guessing perl(FCGI) is dragged in as a result.
This occurs because some of the perl-HTTP-Proxy example scripts use CGI::Util.

Version-Release number of selected component (if applicable):
0.23-10.fc18 (and it would be nice to update to 0.25 while we're at it)

Additional info:
I suspect this can be fixed bu add the perl default filter to the spec file.
Comment 1 Tom "spot" Callaway 2012-04-12 14:02:50 EDT
Fixed in rawhide, you were correct about the perl default filter.

Note You need to log in before you can comment on or make changes to this bug.