Bug 810756 - [abrt] pitivi-0.15.0-1.fc16: discoverer.py:536:_videoPadSeekCb:AttributeError: 'NoneType' object has no attribute 'query_duration'
[abrt] pitivi-0.15.0-1.fc16: discoverer.py:536:_videoPadSeekCb:AttributeError...
Status: CLOSED DUPLICATE of bug 810765
Product: Fedora
Classification: Fedora
Component: pitivi (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
abrt_hash:97bdfbeb03ac0643eb6ab242f15...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-08 19:30 EDT by Andy Esnard
Modified: 2012-04-09 08:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 08:52:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (125 bytes, text/plain)
2012-04-08 19:31 EDT, Andy Esnard
no flags Details

  None (edit)
Description Andy Esnard 2012-04-08 19:30:58 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        python /usr/bin/pitivi
executable:     /usr/bin/pitivi
kernel:         3.3.1-3.fc16.i686.PAE
reason:         discoverer.py:536:_videoPadSeekCb:AttributeError: 'NoneType' object has no attribute 'query_duration'
reported_to:    file: journalisation.jrnl
time:           lun. 09 avril 2012 01:28:48 CEST
uid:            1000
username:       andy

event_log:      Binary file, 125 bytes

backtrace:
:discoverer.py:536:_videoPadSeekCb:AttributeError: 'NoneType' object has no attribute 'query_duration'
:
:Traceback (most recent call last):
:  File "/usr/share/pitivi/python/pitivi/discoverer.py", line 536, in _videoPadSeekCb
:    duration = self.pipeline.query_duration(gst.FORMAT_TIME)[0]
:AttributeError: 'NoneType' object has no attribute 'query_duration'
:
:Local variables in innermost frame:
:self: <pitivi.discoverer.Discoverer object at 0xaa3ee8c>
:pad: <GstPad (---:src0) at 9bbd6e8>

journalisation.jrnl:
:abrt_version:   2.0.7
:cmdline:        python /usr/bin/pitivi
:event_log:      2012-04-09-01:29:17> Smolt profile successfully saved
:executable:     /usr/bin/pitivi
:journalisation.jrnl: 
:kernel:         3.3.1-3.fc16.i686.PAE
:reason:         discoverer.py:536:_videoPadSeekCb:AttributeError: 'NoneType' object has no attribute 'query_duration'
:time:           lun. 09 avril 2012 01:28:48 CEST
:uid:            1000
:username:       andy
:
:backtrace:
::discoverer.py:536:_videoPadSeekCb:AttributeError: 'NoneType' object has no attribute 'query_duration'
::
::Traceback (most recent call last):
::  File "/usr/share/pitivi/python/pitivi/discoverer.py", line 536, in _videoPadSeekCb
::    duration = self.pipeline.query_duration(gst.FORMAT_TIME)[0]
::AttributeError: 'NoneType' object has no attribute 'query_duration'
::
::Local variables in innermost frame:
::self: <pitivi.discoverer.Discoverer object at 0xaa3ee8c>
::pad: <GstPad (---:src0) at 9bbd6e8>
:
:smolt_data:
::
::
::Général
::=================================
::UUID: 0b9d07e2-4b20-4f3e-8733-b59d2e3d9292
::SE: Fedora release 16 (Verne)
::Niveau d'exécution par défaut: Unknown
::Langue: fr_FR.utf8
::Plateforme: i686
::BogoMIPS: 3458.08
::Fabricant du processeurs: GenuineIntel
::Modèle de processeur: Genuine Intel(R) CPU           T2250  @ 1.73GHz
::Stepping du processeur: 8
::Famille de processeur: 6
::Modèle du processeur: 14
::Nombre de processeurs: 2
::Vitesse du processeur: 1729
::Mémoire du système: 1003
::Swap du système: 2015
::Fabricant: HP-Pavilion
::Système: RR460AA-ABF s7740.fr 
::Type d'ordinateur: Desktop
::Noyau: 3.3.1-3.fc16.i686.PAE
::SELinux activé: 1
::Stratégie SELinux: targeted
::SELinux strict: Enforcing
::MythTV Remote: Unknown
::MythTV Role: Unknown
::MythTV Theme: Unknown
::MythTV Plugin: 
::MythTV Tuner: -1
::
::
::Périphériques
::=================================
::(4545:22545:4156:10820) pci, firewire_ohci, FIREWIRE, FW322/323
::(32902:10202:4156:10820) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
::(32902:10181:4156:10820) pci, ahci, STORAGE, 82801GBM/GHM (ICH7 Family) SATA AHCI Controller
::(32902:10207:4156:10820) pci, ata_piix, STORAGE, 82801G (ICH7 Family) IDE Controller
::(32902:10173:4156:10820) pci, None, PCI/ISA, 82801GHM (ICH7-M DH) LPC Interface Bridge
::(32902:10200:4156:10820) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
::(32902:9288:4156:10820) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
::(4318:477:4163:843) pci, nvidia, VIDEO, G72 [GeForce 7500 LE]
::(32902:10185:4156:10820) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
::(32902:10184:4156:10820) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
::(32902:10144:4156:10820) pci, None, HOST/PCI, Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub
::(32902:10186:4156:10820) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
::(32902:10204:4156:10820) pci, e100, ETHERNET, N10/ICH 7 Family LAN Controller
::(32902:10187:4156:10820) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
::(32902:10188:4156:10820) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
::(32902:10145:4156:10820) pci, pcieport, PCI/PCI, Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port
::
::
::Informations sur le système de fichiers
::=================================
::device mtpt type bsize frsize blocks bfree bavail file ffree favail
::-------------------------------------------------------------------
::/dev/mapper/VolGroup-lv_root / ext4 4096 4096 13081819 6206200 5550840 3276800 2551637 2551637
::/dev/sda2 /boot ext4 1024 1024 508745 410955 385355 128016 127745 127745
::/dev/mapper/VolGroup-lv_home /home ext4 4096 4096 7493558 1629367 1253764 1880480 1731718 1731718
::/dev/sdb1 WITHHELD vfat 4096 4096 1955344 802952 802952 0 0 0
::
:
:END:
:

smolt_data:
:
:
:Général
:=================================
:UUID: 0b9d07e2-4b20-4f3e-8733-b59d2e3d9292
:SE: Fedora release 16 (Verne)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_FR.utf8
:Plateforme: i686
:BogoMIPS: 3458.08
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Genuine Intel(R) CPU           T2250  @ 1.73GHz
:Stepping du processeur: 8
:Famille de processeur: 6
:Modèle du processeur: 14
:Nombre de processeurs: 2
:Vitesse du processeur: 1729
:Mémoire du système: 1003
:Swap du système: 2015
:Fabricant: HP-Pavilion
:Système: RR460AA-ABF s7740.fr 
:Type d'ordinateur: Desktop
:Noyau: 3.3.1-3.fc16.i686.PAE
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(4545:22545:4156:10820) pci, firewire_ohci, FIREWIRE, FW322/323
:(32902:10202:4156:10820) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:10181:4156:10820) pci, ahci, STORAGE, 82801GBM/GHM (ICH7 Family) SATA AHCI Controller
:(32902:10207:4156:10820) pci, ata_piix, STORAGE, 82801G (ICH7 Family) IDE Controller
:(32902:10173:4156:10820) pci, None, PCI/ISA, 82801GHM (ICH7-M DH) LPC Interface Bridge
:(32902:10200:4156:10820) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:9288:4156:10820) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(4318:477:4163:843) pci, nvidia, VIDEO, G72 [GeForce 7500 LE]
:(32902:10185:4156:10820) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4156:10820) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:10144:4156:10820) pci, None, HOST/PCI, Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub
:(32902:10186:4156:10820) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10204:4156:10820) pci, e100, ETHERNET, N10/ICH 7 Family LAN Controller
:(32902:10187:4156:10820) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:4156:10820) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:(32902:10145:4156:10820) pci, pcieport, PCI/PCI, Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup-lv_root / ext4 4096 4096 13081819 6206200 5550840 3276800 2551637 2551637
:/dev/sda2 /boot ext4 1024 1024 508745 410955 385355 128016 127745 127745
:/dev/mapper/VolGroup-lv_home /home ext4 4096 4096 7493558 1629367 1253764 1880480 1731718 1731718
:/dev/sdb1 WITHHELD vfat 4096 4096 1955344 802952 802952 0 0 0
:
Comment 1 Andy Esnard 2012-04-08 19:31:06 EDT
Created attachment 576088 [details]
File: event_log
Comment 2 Gwyn Ciesla 2012-04-09 08:52:13 EDT

*** This bug has been marked as a duplicate of bug 810765 ***

Note You need to log in before you can comment on or make changes to this bug.