Bug 810808 - RFE: secondary inputs not handled in overview
RFE: secondary inputs not handled in overview
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 04:57 EDT by Alon Levy
Modified: 2014-08-04 18:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 10:45:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alon Levy 2012-04-09 04:57:03 EDT
Description of problem:
Only primary keyboard and mouse can interact with the overview.

Version-Release number of selected component (if applicable):
gnome-shell-3.4.0-1.fc17.x86_64
mutter-3.4.0-1.fc17.x86_64

(not sure which is responsible so providing both)

How reproducible:
100%

Steps to Reproduce:
1. xinput create-master test
the new "test keyboard" has id 14
insert a second keyboard, id 17
2. xinput reattach 17 14
3. press win key
4. press win key
  
Actual results:
after 3 you are in overview, but 4 doesn't take you out of it.

Expected results:
be back in standard mode.

Additional info:

Couldn't yet reproduce this with XTest since I haven't figured out how to send an event to the "test XTEST keyboard"

This happens with the mouse too - you can use the hotspot, click any icon/window in overview mode when using the secondary mouse (a mouse attached to "test pointer" created with step 1).

There are other problems with multiple pointers, such as switching focus not working unless you click the title bar, instead of working anywhere in the window area you press (you can see this by just doing "xinput create-master bla" and not attaching any pointers to it, so easy to reproduce).
Comment 1 Owen Taylor 2012-04-09 10:45:11 EDT
There's an upstream XI2 branch of mutter you can try out. We aren't going to do anything on this in the scope of Fedora (especially since I'm not aware of any real use cases for this other than fun.)

Note You need to log in before you can comment on or make changes to this bug.