Bug 810876 - Long Cloud Resource Names overrun display areas
Long Cloud Resource Names overrun display areas
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jiri Tomasek
wes hayutin
: Triaged
: 851250 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 10:00 EDT by Ronelle Landy
Modified: 2012-12-04 10:03 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When naming a Cloud Resource Zone with over 50 characters, the name did not fit in the heading area and was covered by other graphic user interface elements. This bug fix updates layout.scss by expanding the heading area to fit long names.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:03:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cloud Resource Zone name over (461.59 KB, image/png)
2012-04-09 10:00 EDT, Ronelle Landy
no flags Details
Cloud Resource Zone name partially hidden (163.53 KB, image/png)
2012-04-09 10:01 EDT, Ronelle Landy
no flags Details
Monitor - long name ... (104.22 KB, image/png)
2012-09-20 17:40 EDT, Ronelle Landy
no flags Details
CRZ Detail (87.31 KB, image/png)
2012-09-20 17:41 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Ronelle Landy 2012-04-09 10:00:23 EDT
Created attachment 576221 [details]
Cloud Resource Zone name over

Description of problem:

Long Cloud Resource Zone names do not fit in to designed display areas/boxes/headings and are partially covered by other GUI elements. 


Steps to Reproduce:
1. Create a new Cloud Resource Zone with a long name: for example 'Now make a Third Resource Zone With a Longer Name Cloud Resource Zone'
2. Click on the 'Monitor', 'Overview' tab. 
3. See that the name box for the resource zone does not expand to contain the name and the name overruns the boundaries 9see attached screenshot)
4. Now click on the Cloud Resource Zone name
5. See that the displayed name in the heading is partially covered by the 'New Application' and other buttons. (see attached screenshot) 
  
rpms tested: 

rpm -qa |grep aeolus
aeolus-conductor-daemons-0.8.7-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
Comment 1 Ronelle Landy 2012-04-09 10:01:27 EDT
Created attachment 576222 [details]
Cloud Resource Zone name partially hidden
Comment 3 Dave Johnson 2012-08-24 10:14:04 EDT
*** Bug 851250 has been marked as a duplicate of this bug. ***
Comment 4 Jiri Tomasek 2012-08-31 08:41:10 EDT
Fix posted. Pull request: https://github.com/aeolusproject/conductor/pull/25
Comment 5 Matt Wagner 2012-09-05 11:41:55 EDT
Pushed to master and 1.1:

commit 0eb4c246525d4383424a6b843c9e97c8ab5ba241
Author: Jiri Tomasek <jtomasek@redhat.com>
Date:   Fri Aug 31 14:27:52 2012 +0200

    BZ810876 Fix long Pool name overflow in Overview page
    (cherry picked from commit e71ce4d795e48b9b383d3f25083879637fa4f1ca)
Comment 6 Steve Linabery 2012-09-07 17:50:09 EDT
in build aeolus-conductor-0.13.3-1.el6cf
Comment 8 Ronelle Landy 2012-09-20 17:40:03 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

A long Cloud Resource Zone name is handled now by ... or expanding the heading. See attached screenshots.

Marking this BZ as 'verified'.
Comment 9 Ronelle Landy 2012-09-20 17:40:58 EDT
Created attachment 615134 [details]
Monitor - long name ...
Comment 10 Ronelle Landy 2012-09-20 17:41:22 EDT
Created attachment 615135 [details]
CRZ Detail
Comment 12 errata-xmlrpc 2012-12-04 10:03:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.