Bug 810942 - system-config-printer not work without polkit-gnome-authentication-agent-1, no error message
Summary: system-config-printer not work without polkit-gnome-authentication-agent-1, n...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 16
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-09 17:17 UTC by Frantisek Hanzlik
Modified: 2013-02-13 23:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-13 23:53:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Frantisek Hanzlik 2012-04-09 17:17:02 UTC
Description of problem:
It seems as F16 system-config-printer-1.3.8 isn't able authenticate user (and therefore is rather nonfunctional) without PolicyKit desktop authentication agent
(e.g. /usr/libexec/polkit-gnome-authentication-agent-1 from polkit-gnome package).
For example isn't possible create/manage printers, display/modify cups server setting


Version-Release number of selected component (if applicable):
system-config-printer-1.3.8-4.fc16.i686


Expected results:

- ability use system-config-printer in local sessions without polkit agent running

- ability use system-config-printer in remote X session (e.g. ssh -X remoteHost)

Comment 1 Fedora End Of Life 2013-01-16 20:29:04 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Fedora End Of Life 2013-02-13 23:53:11 UTC
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.