This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 810957 - /conductor/images page does not auto-refresh to show new available images
/conductor/images page does not auto-refresh to show new available images
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Imre Farkas
wes hayutin
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 14:18 EDT by Ronelle Landy
Modified: 2016-09-20 01:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
When a user pushed a new image, the image page in Conductor did not update in real-time. This bug fix adds real-time updates to the image page in Conductor.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:03:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/conductor/images before manual page refresh (158.91 KB, image/png)
2012-04-09 14:19 EDT, Ronelle Landy
no flags Details
/conductor/images after manual page refresh (162.34 KB, image/png)
2012-04-09 14:20 EDT, Ronelle Landy
no flags Details
Auto-update (123.86 KB, image/png)
2012-09-20 17:59 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Ronelle Landy 2012-04-09 14:18:55 EDT
Description of problem:
Not sure if the /conductor/images page *should* auto-refresh but it does not seem to... Built and pushed a new image and that image was not visible on the /conductor/images page w/o refreshing the page.


Steps to Reproduce:
1. Open a browser pointing to the /images page of a working Conductor instance
2. Use aeolus-image (cli) to build and push a new image
3. Check the imagefactory log to ensure the image was built and pushed successfully
4. Check the conductor/images page in the open browser. Note that the new image is not visible in the list of images before a manual page refresh. see attached screenshots.

/var/log/imagefactory.log shows that the image is built and successfully pushed to the mock provider:

2012-04-09 13:56:20,490 DEBUG imgfac.BuildJob.BuildJob thread(b5a61e41) Message: Builder (b5a61e41-de50-48ce-a7fc-36b6c01c7de7) changed status from PUSHING to COMPLETED
2012-04-09 13:56:20,490 DEBUG imgfac.BuildJob.BuildJob thread(b5a61e41) Message: b5a61e41-de50-48ce-a7fc-36b6c01c7de7 for mock about to exit None queue...
2012-04-09 13:56:20,490 DEBUG imgfac.ImageWarehouse.ImageWarehouse thread(b5a61e41) Message: Setting metadata ({'latest_build': 'a4d34c47-84f9-4b01-88ba-980f88bef37e'}) for http://localhost:9090/images/12ba3b70-826d-11e1-97de-00215e202e2e
2012-04-09 13:56:20,492 DEBUG imgfac.ImageWarehouse.ImageWarehouse thread(b5a61e41) Message: Setting metadata ({'latest_unpushed': None}) for http://localhost:9090/images/12ba3b70-826d-11e1-97de-00215e202e2e

  
rpms tested:

rpm -qa |grep aeolus
aeolus-conductor-daemons-0.8.7-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
Comment 1 Ronelle Landy 2012-04-09 14:19:37 EDT
Created attachment 576272 [details]
/conductor/images before manual page refresh
Comment 2 Ronelle Landy 2012-04-09 14:20:16 EDT
Created attachment 576273 [details]
/conductor/images after manual page refresh
Comment 4 Imre Farkas 2012-09-05 11:05:23 EDT
Until now, there was no auto update feature for that page, but the following commit adds it:

commit c7b1b172701650b4e002f9deb76ab94c3a050e62
Author: Imre Farkas <ifarkas@redhat.com>
Date:   Wed Sep 5 16:02:49 2012 +0200

    Mustachifying images#index
    
    https://bugzilla.redhat.com/show_bug.cgi?id=810957
    (cherry picked from commit 19f85cebdf8833367fe30e6be7b86c10f44c64fb)
Comment 5 Imre Farkas 2012-09-05 11:05:52 EDT
The pull request:
https://github.com/aeolusproject/conductor/pull/41
Comment 7 Ronelle Landy 2012-09-20 17:58:32 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

The /conductor/images page does auto-refresh to show new images.

See attached screenhot - that shows two entries for RHEL6-2Basic - built on two different days. The second entry showed up after automatic page refresh.

Marking this BZ as 'verified'.
Comment 8 Ronelle Landy 2012-09-20 17:59:10 EDT
Created attachment 615151 [details]
Auto-update
Comment 10 errata-xmlrpc 2012-12-04 10:03:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.