Bug 810970 - Cannot start 4.2.0-0.6.I201204051114.fc18.x86_64
Cannot start 4.2.0-0.6.I201204051114.fc18.x86_64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 14:46 EDT by Andrew Overholt
Modified: 2014-01-12 19:26 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 12:53:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
startup log (79.68 KB, text/plain)
2012-04-09 14:46 EDT, Andrew Overholt
no flags Details
startup log after a few changes (284.36 KB, text/plain)
2012-04-09 15:09 EDT, Andrew Overholt
no flags Details

  None (edit)
Description Andrew Overholt 2012-04-09 14:46:11 EDT
Created attachment 576278 [details]
startup log

Description of problem:
On F-16 x86_64, upgrading eclipse and dependencies to rawhide versions (see below for transaction log) renders eclipse un-startable.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. yum --enablerepo=rawhide upgrade eclipse
2. eclipse -debug -consolelog
  
Actual results:
Startup failure (I'll attach the log)

Expected results:
Start up with 4.2 goodness :)

Additional info:

yum transaction log:

Apr 09 14:08:37 Updated: ant-1.8.3-1.fc18.noarch
Apr 09 14:08:38 Installed: junit-4.10-4.fc17.noarch
Apr 09 14:08:41 Updated: 1:icu4j-eclipse-4.4.2.2-11.fc18.noarch
Apr 09 14:08:43 Updated: 1:eclipse-swt-4.2.0-0.6.I201204051114.fc18.x86_64
Apr 09 14:08:46 Updated: objectweb-asm-3.3.1-3.fc17.noarch
Apr 09 14:08:47 Updated: jsch-0.1.46-2.fc18.noarch
Apr 09 14:08:48 Updated: ant-jsch-1.8.3-1.fc18.noarch
Apr 09 14:08:48 Updated: ant-junit-1.8.3-1.fc18.noarch
Apr 09 14:08:50 Updated: ant-testutil-1.8.3-1.fc18.noarch
Apr 09 14:08:51 Updated: ant-jdepend-1.8.3-1.fc18.noarch
Apr 09 14:08:56 Updated: ant-commons-net-1.8.3-1.fc18.noarch
Apr 09 14:08:58 Updated: ant-apache-xalan2-1.8.3-1.fc18.noarch
Apr 09 14:08:59 Updated: ant-apache-bsf-1.8.3-1.fc18.noarch
Apr 09 14:09:01 Updated: ant-apache-regexp-1.8.3-1.fc18.noarch
Apr 09 14:09:02 Updated: ant-apache-log4j-1.8.3-1.fc18.noarch
Apr 09 14:09:04 Updated: ant-apache-oro-1.8.3-1.fc18.noarch
Apr 09 14:09:05 Updated: ant-antlr-1.8.3-1.fc18.noarch
Apr 09 14:09:06 Updated: ant-javamail-1.8.3-1.fc18.noarch
Apr 09 14:09:08 Updated: ant-apache-bcel-1.8.3-1.fc18.noarch
Apr 09 14:09:09 Installed: ant-scripts-1.8.3-1.fc18.noarch
Apr 09 14:09:11 Updated: ant-jmf-1.8.3-1.fc18.noarch
Apr 09 14:09:13 Updated: ant-apache-resolver-1.8.3-1.fc18.noarch
Apr 09 14:09:14 Updated: ant-commons-logging-1.8.3-1.fc18.noarch
Apr 09 14:09:16 Updated: ant-swing-1.8.3-1.fc18.noarch
Apr 09 14:09:19 Installed: felix-gogo-runtime-0.10.0-4.fc17.noarch
Apr 09 14:09:21 Installed: stax2-api-3.1.1-3.fc17.noarch
Apr 09 14:09:22 Installed: woodstox-core-4.1.2-2.fc17.noarch
Apr 09 14:09:24 Installed: felix-osgi-foundation-1.2.0-8.fc17.noarch
Apr 09 14:09:25 Installed: felix-osgi-compendium-1.4.0-9.fc18.noarch
Apr 09 14:09:27 Installed: felix-shell-1.4.2-6.fc18.noarch
Apr 09 14:09:29 Installed: felix-framework-4.0.2-1.fc17.noarch
Apr 09 14:09:30 Installed: felix-utils-1.1.0-4.fc17.noarch
Apr 09 14:09:32 Installed: felix-bundlerepository-1.6.6-3.fc17.noarch
Apr 09 14:09:33 Installed: felix-gogo-command-0.12.0-3.fc17.noarch
Apr 09 14:09:36 Installed: jakarta-taglibs-standard-1.1.2-4.fc18.noarch
Apr 09 14:09:38 Updated: apache-commons-codec-1.6-2.fc17.noarch
Apr 09 14:09:40 Installed: felix-gogo-shell-0.10.0-3.fc17.noarch
Apr 09 14:09:42 Installed: geronimo-annotation-1.0-7.fc18.noarch
Apr 09 14:10:11 Updated: jetty-8.1.0-4.fc18.noarch
Apr 09 14:10:14 Installed: 1:eclipse-emf-core-2.8.0-0.6.I201204051114.fc18.x86_64
Apr 09 14:10:20 Updated: 1:eclipse-rcp-4.2.0-0.6.I201204051114.fc18.x86_64
Apr 09 14:10:28 Updated: eclipse-emf-2.8.0-0.4.postM6.fc18.noarch
Apr 09 14:11:10 Updated: 1:eclipse-platform-4.2.0-0.6.I201204051114.fc18.x86_64
Apr 09 14:11:19 Updated: 1:eclipse-jdt-4.2.0-0.6.I201204051114.fc18.x86_64
Apr 09 14:11:47 Updated: 1:eclipse-pde-4.2.0-0.6.I201204051114.fc18.x86_64
Apr 09 14:12:06 Erased: junit4-4.8.2-2.fc15.noarch
Comment 1 Andrew Overholt 2012-04-09 15:09:25 EDT
Created attachment 576286 [details]
startup log after a few changes

I removed all non-SDK eclipse RPMs and ended up with this:

$ rpm -qa | grep eclipse
tomcat5-jasper-eclipse-5.5.31-3.fc15.noarch
maven-eclipse-plugin-2.8-5.fc16.noarch
eclipse-rcp-4.2.0-0.6.I201204051114.fc18.x86_64
eclipse-platform-4.2.0-0.6.I201204051114.fc18.x86_64
eclipse-emf-core-2.8.0-0.6.I201204051114.fc18.x86_64
icu4j-eclipse-4.4.2.2-11.fc18.noarch
eclipse-pde-4.2.0-0.6.I201204051114.fc18.x86_64
eclipse-swt-4.2.0-0.6.I201204051114.fc18.x86_64
eclipse-jdt-4.2.0-0.6.I201204051114.fc18.x86_64

I also updated apache-commons-logging since I somehow thought it was relevant.

I then put this into ~/.options:

$ cat ~/.options 
org.eclipse.equinox.p2.core/debug=true
org.eclipse.equinox.p2.core/reconciler=true

and ran with this:

eclipse -consolelog -debug -clean -data /tmp/test42build2

I've attached the output of that.
Comment 2 Andrew Overholt 2012-04-09 15:12:35 EDT
Oh, I also tried setting my system java and javac alternatives to OpenJDK 6 instead of 7 and it failed (the above log was taken while using 6).
Comment 3 Krzysztof Daniel 2012-04-10 04:07:57 EDT
Alex diagnosed this problem as atinject missing proper manifest.mf. It is hard to disagree. 

Andrew,
could you:
restore default java 7 alternative
update atinject to 1.6?

In the meantime I have added requires >= 1.6 to atinject. The bug will be closed when Eclipse is built and pushed into rawhide before the end of the week (13.04), if only Andrew confirms the solution.
Comment 4 Krzysztof Daniel 2012-04-10 04:09:16 EDT
For logging purposes:
commit 4a6baa9a886189d52e6c32b6f7a98234499266c9
Comment 5 Andrew Overholt 2012-04-10 08:16:08 EDT
I can confirm that updating atinject does indeed fix this and I'm able to start and use Eclipse.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.