Bug 811101 - Dell Inspiron 9300 laptop touchpad drifting in Fedora 17, but not Fedora 16
Dell Inspiron 9300 laptop touchpad drifting in Fedora 17, but not Fedora 16
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 02:30 EDT by Scott Dowdle
Modified: 2012-06-26 01:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 01:38:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2012-04-10 02:30:11 EDT
I've been trying out the development progress of Fedora 17 on my fairly aged Dell Inspiron 9300.  The most recent build I've tried has been Fedora 17 Beta RC3 built on April 4th, 2012.

Every release I've tried so far has this really weird issue with the trackpad.  When I touch with my finger to move the mouse around, I'll slide my finger around to get the pointer where I want it.  It works fine with Fedora 16... but with Fedora 17... when I stop moving... the mouse continues to drift in the direction it was going until I lift my finger up off of the trackpad.  It is really strange.

I'm not really sure what device the trackpad is.  Here's all can find in dmesg searching for mouse:

[    1.299944] i8042: PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[    1.304632] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.304639] serio: i8042 AUX port at 0x60,0x64 irq 12
[    1.304745] mousedev: PS/2 mouse device common for all mice

I primarily use KDE but I believe the same behavior is experienced in other desktop environments.  I adjusted the various mouse settings in KDE System Settings but nothing seemed to help... as the mouse continues to drift in the direction it was moved... even when the finger stops moving... until the finger is lifted off of the touchpad.

Please note that this is NOT a hardware malfunction... as switching back to Fedora 16 completely fixes the problem... switch back to Fedora 17 and it is broken again.
Comment 1 Josh Boyer 2012-04-10 09:55:16 EDT
When you say Fedora 16 works fine, what F16 kernel are you running.  Same question for F17.
Comment 2 Scott Dowdle 2012-04-10 10:53:32 EDT
On Fedora 16 I've basically run every kernel that has been released from the original release and all updates to the current kernel at time of writing: kernel-3.3.1-3.fc16.i686

For 17, every one I've tried so far including the one released with Fedora 17 Beta RC3 which is: 3.3.0-1.fc17.i686

This evening I'll try other desktop environments to make sure it isn't just KDE.

Just to clarify, the drifting behavior isn't just annoying, it makes precise mouse control very difficult.  Trying to stop on a small target (like a scroll bar arrow) is hard to do the first time and not any better subsequent tries.
Comment 3 Josh Boyer 2012-04-10 14:17:08 EDT
At this point, the F16 and F17 kernels are very very similar.  They're both based on 3.3.1, and there are no additional patches in the input/HID layers in F17.  This sounds like it might be a difference in the f16/f17 versions of evdev perhaps.

Peter, can you take a look?
Comment 4 Scott Dowdle 2012-04-10 23:26:43 EDT
Just wanted to mention that I downloaded the Fedora 17 Beta RC4 32-bit XFCE media and booted from that to test... and had the same issue with the touchpad... so it is desktop independent.
Comment 5 Scott Dowdle 2012-04-14 10:46:49 EDT
Same results on a Dell Latitude D600 (Pentium D) laptop.  The removing the module and then modprobing it makes it work.
Comment 6 Scott Dowdle 2012-04-14 10:48:35 EDT
Opps, that last comment... was meant for another bug.  But yes, the touchpad issue also affects the Dell Latitude D600... and I haven't found a way to fix it.
Comment 7 Peter Hutterer 2012-04-19 21:34:02 EDT
This should have been fixed with the very last update. 
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.5.99.903-3.20120419git11d892964.fc17

Please give it a try.
Comment 8 Scott Dowdle 2012-04-23 17:22:31 EDT
Yes that fixed it for me.  I'll add some karma.

Note You need to log in before you can comment on or make changes to this bug.