Bug 811134 - RHEV-H 6.3: Auto install RHEV-H with "ssh_pwauth" parameter, it does not work
RHEV-H 6.3: Auto install RHEV-H with "ssh_pwauth" parameter, it does not work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
medium Severity high
: rc
: 6.3
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 04:55 EDT by cshao
Modified: 2016-04-26 10:24 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 10:20:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cshao 2012-04-10 04:55:11 EDT
Description of problem:
Auto install RHEV-H with "ssh_pwauth=1" parameter, it does not work.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120330.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Auto install RHEV-H with "ssh_pwauth=1" parameter.
2. Reboot RHEV-H and check ssh password authentication.

  
Actual results:
ssh password authentication is currently disable.

grep PasswordAuthentication /etc/ssh/sshd_config
#PasswordAuthentication yes

Expected results:
ssh password authentication is enable.

Additional info:
There is no such issue in rhev-hypervisor6-6.2-20120409.0.el6_2, so it is a regression bug.
Comment 3 cshao 2012-04-10 05:43:47 EDT
Miss one line when copy, 
Actual results should be:
ssh password authentication is currently disable.

grep PasswordAuthentication /etc/ssh/sshd_config
#PasswordAuthentication yes
PasswordAuthentication no
Comment 4 Fabian Deutsch 2012-04-11 11:30:20 EDT
http://gerrit.ovirt.org/#change,3472
Comment 7 Guohua Ouyang 2012-04-28 01:17:19 EDT
verified with rhevh-6.3-20120426.2, auto install with ssh_pwauth=1 can enable ssh
Comment 8 Mike Burns 2012-06-13 13:04:57 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the ssh_pwauth parameter was not handled correctly during automatic installation.  The parameter is now read and processed and the result persisted for future reboots.
Comment 9 Stephen Gordon 2012-06-13 19:33:08 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Previously, the ssh_pwauth parameter was not handled correctly during automatic installation.  The parameter is now read and processed and the result persisted for future reboots.+Previously, the ssh_pwauth parameter was not handled correctly during automatic installation. The parameter is now read and processed and the result persisted for future reboots.
Comment 10 Stephen Gordon 2012-06-15 09:57:00 EDT
Deleted Technical Notes Contents.

Old Contents:
Previously, the ssh_pwauth parameter was not handled correctly during automatic installation. The parameter is now read and processed and the result persisted for future reboots.
Comment 12 errata-xmlrpc 2012-07-19 10:20:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.