Bug 811186 - mails: Precedence: bulk
mails: Precedence: bulk
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 06:56 EDT by Harald Reindl
Modified: 2012-04-12 07:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 07:18:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2012-04-10 06:56:13 EDT
mails triggered by scripts are containing "Auto-Submitted: auto-generated" header which is good, but they also should contain "Precedence: bulk" because some auto-reply implementations are looking at this header to supress replies 

 * Precedence: bulk
 * Auto-Submitted: auto-generated

i love the current behavior writing a script and if it generates any output get a mail to the admin-group, but it would be nice if one of the group is at holidays not trigger replies
Comment 1 Marcela Mašláňová 2012-04-10 10:15:03 EDT
From RFC3834
<citation>
A response MAY include a Precedence field [I4.RFC2076] in order to
discourage responses from some kinds of responders which predate this
specification.  The field-body of the Precedence field MAY consist of
the text "junk", "list", "bulk", or other text deemed appropriate by
the responder.  Because the Precedence field is non-standard and its
interpretation varies widely, the use of Precedence is not
specifically recommended by this specification, nor does this
specification recommend any particular value for that field.
</citation>

I guess it can't break anything if I add a line into do_command.c file.
Comment 2 Harald Reindl 2012-04-10 10:20:28 EDT
this would be very nice!

most auto-responders and mailing-lists are using this header
even postfix mailing-list and Wietse Venema is really a
hardliner in context of smtp
Comment 3 Marcela Mašláňová 2012-04-12 07:18:43 EDT
Thanks for idea. I pushed it as commit 1d42d62a372125fe9d5c97136dff042d2f2aba79

I'll add it into the next cronie release.
Comment 4 Harald Reindl 2012-04-12 07:25:17 EDT
thank you!

Note You need to log in before you can comment on or make changes to this bug.