Bug 811195 - Document converting Citrix Xen PV guest with virt-p2v.
Document converting Citrix Xen PV guest with virt-p2v.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 07:34 EDT by yuping zhang
Modified: 2015-03-12 13:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-12 13:20:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuping zhang 2012-04-10 07:34:06 EDT
Description of problem:
Can not convert Citrixe Xen PV guest directly with virt-p2v as Xen pv guest can not boot from CDROM or PXE.
There is a workaround:
1.Create a HVM guest,
2.Attach the pv guest image to HVM guest,
3.Boot virt-p2v iso from HVM guest,
4.Select the pv guest image to convert it.

Need to document this workaround.

Version-Release number of selected component (if applicable):
Virt-p2v-0.8.6-2.iso

How reproducible:


Steps to Reproduce:
1.
2.
3.
 
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2012-05-03 00:48:30 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 Richard W.M. Jones 2015-03-12 13:20:05 EDT
We don't test conversions from Citrix Xen, so documenting it
would likely be inadvisable.

I'm closing this bug:

 - virt-p2v has been rewritten for RHEL 7.2

 - Unofficial previews of the new version are available:
   http://oirase.annexia.org/virt-p2v/

 - If a similar bug occurs with the new version of virt-p2v,
   please open a new bug against Red Hat Enterprise Linux 7 / libguestfs

Note You need to log in before you can comment on or make changes to this bug.