Bug 811225 - Early kernel panic 3.3+ on Dell XPS
Early kernel panic 3.3+ on Dell XPS
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
: 809158 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 09:26 EDT by Nathan Samson
Modified: 2012-04-25 23:26 EDT (History)
12 users (show)

See Also:
Fixed In Version: kernel-2.6.43.2-6.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 00:28:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Samson 2012-04-10 09:26:18 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120409 Firefox/13.0a2

Booting the kernel 3.3.0 and 3.3.1 fails with an early kernel panic on dell XPS L501X machines.
(PANIC: early exception 06 rip 10:ffffffff81d369ef error 0 cr2 0) directly after Loading initramfs

I've found two forum posts of people with the same problem and exactly the same hardware.

The forum post adds a workaround, disabling the wifi in the BIOS. I did not try this, but it isn't a solution for me.

Reproducible: Always

Steps to Reproduce:
1. Buy a dell XPS Studio 15
2. Install fedora 
3. Upgrade to latest kernel (3.3.1)
4. Reboot and try to boot kernel 3.3.1
Actual Results:  
Kernel panic

Expected Results:  
Boots

http://forums.fedoraforum.org/showthread.php?t=278551 and http://forums.fedoraforum.org/showthread.php?t=278617
Comment 1 James Heather 2012-04-11 03:56:05 EDT
I'm seeing this too. Same hardware, same problem. Disabling wifi in the BIOS avoids the kernel panic, but leaves me with a largely pointless laptop.

It's now been reported upstream:

https://bugzilla.kernel.org/show_bug.cgi?id=43076

I'd encourage anyone hitting this bug to add a comment to the upstream entry. The more chatter, the more likely it is to get looked at.

This is a major issue because you can't even solve it by switching distro.
Comment 2 lopezmen 2012-04-17 16:18:44 EDT
I have the same issue running fedora 16 on kernels 3.2.10-3.3.1 but on a dell
studio xps 13 (studio xps 1340).

I could not disable the wifi thru the bios so i couldn't say if is the wifi
or not.
Comment 3 Daniele Viganò 2012-04-18 05:16:28 EDT
Same hardware and same troubles as Nathan Samson
Comment 4 bertu.torrent 2012-04-18 11:35:00 EDT
Same problem with dell studio xps 1340
Comment 5 Daniele Viganò 2012-04-20 12:14:16 EDT
I've recompiled the Fedora 16 3.3.2 kernel from update-testing (3.3.2-1.fc16) with the patch from Tejun Heo (https://bugzilla.kernel.org/show_bug.cgi?id=43098) and I can confirm that now my Dell XPS 15 is booting and working without any issue.

If someone wants to test the patched 3.3.2-1.fc16 I can provide x86_64 RPMs.

Thanks to all.
Comment 6 Josh Boyer 2012-04-20 12:28:04 EDT
*** Bug 809158 has been marked as a duplicate of this bug. ***
Comment 7 Josh Boyer 2012-04-20 12:28:57 EDT
OK.  We'll get this pulled in soon.  Thank you very much for the pointer!
Comment 8 Fedora Update System 2012-04-21 11:21:15 EDT
kernel-3.3.2-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.2-8.fc17
Comment 9 Fedora Update System 2012-04-21 12:25:32 EDT
kernel-3.3.2-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.2-6.fc16
Comment 10 Fedora Update System 2012-04-21 12:45:33 EDT
kernel-2.6.43.2-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.43.2-6.fc15
Comment 11 Fedora Update System 2012-04-21 17:07:09 EDT
Package kernel-3.3.2-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.2-8.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6344/kernel-3.3.2-8.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-04-24 00:28:09 EDT
kernel-3.3.2-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-04-24 10:53:23 EDT
kernel-3.3.2-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Johan Godfried 2012-04-24 16:35:36 EDT
I have a Dell XPS17 and I have been having this problem since the first kernel 3.3 update on FC16 x86_64 (The last working kernel was kernel-3.2.10-3.fc16).

I can confirm that kernel-3.3.2-6.fc16 is booting successfully without the PANIC.
Comment 15 Marc Ashford 2012-04-25 19:20:15 EDT
I just ran my updates and I have a Kernel Panic error also. Error: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0). I do not have a Dell. I have a Gateway DX 4200 with Nvidia 9600, Specs found here: http://support.gateway.com/s/PC/DX4200/1015576R/1015576Rsp3.shtml.

I have tried to rebuild the boot partition and it still will not load. I am not able to boot to previouse 3.3.1-3 as the system will not let me install the proper nvidia drivers for that Kernel. The fs is listed correctly as is the 0,0.

I hope an update is pushed before having to move to 17 as I am looking at reinstalling to fix this. Any help would be greatly appriciated!

Thanks,
Marc
Currently running on USB Live Fedora 16 to post this :-(
Comment 16 Fedora Update System 2012-04-25 23:26:46 EDT
kernel-2.6.43.2-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.