This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 811238 - Disable contact photos and disable HTML image loading to prevent #810256 from occurring
Disable contact photos and disable HTML image loading to prevent #810256 from...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: beta
: 6.4
Assigned To: Matthew Barnes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 10:03 EDT by David Jaša
Modified: 2013-05-13 05:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 05:02:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-04-10 10:03:55 EDT
Description of problem:
Based on https://bugzilla.redhat.com/show_bug.cgi?id=810256#c3, it would be sound to default to sane settings:
HTML Messages tab -> Loading Images: "Never load images from the internet"
Headers tab -> Sender Photograph: "Show the photograph ..."

The concept could be even stretched to some system-wide setting that would disable "Load images in messages from contacts" and "Show the photograph ..." altogether so that administrators of systems can prevent #810256 from happening on systems of other users.

Version-Release number of selected component (if applicable):
evolution-2.28.3-23.el6.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Milan Crha 2012-04-11 02:50:15 EDT
The change makes sense, though the default values in evolution-mail.schemas file looks to be correct, namely:
   /apps/evolution/mail/junk/lookup_addressbook
   false

   /apps/evolution/mail/display/load_http_images
   0 (means Never load images from the net)

   /apps/evolution/mail/display/sender_photo
   false

   /apps/evolution/mail/display/photo_local
   true
Comment 2 RHEL Product and Program Management 2012-07-10 02:35:18 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 19:09:14 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 RHEL Product and Program Management 2012-12-14 02:07:53 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Milan Crha 2013-05-09 14:42:06 EDT
I'm wondering, whether it's enabled, because evolution was already run on the machine, aka due to an update from a previous version or a backup restore.
Comment 6 Tomas Pelka 2013-05-13 05:02:26 EDT
I'm observing the same behaviour ad Milan described on new profile without previous evo conf.

Clonsing, feel free to reopen if needed.

Note You need to log in before you can comment on or make changes to this bug.