Bug 811249 - kernel oops while using gnome-bluetooth
kernel oops while using gnome-bluetooth
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-04-10 10:29 EDT by Máirín Duffy
Modified: 2012-11-14 10:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-11-14 10:17:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
photo of the error message (2.15 MB, image/jpeg)
2012-04-10 10:29 EDT, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2012-04-10 10:29:48 EDT
Created attachment 576484 [details]
photo of the error message

Description of problem:

I paired my Android phone to my Fedora 16 GNOME desktop via the GNOME shell bluetooth menu. I browsed the device from the GNOME shell bluetooth menu. (I was trying to get some whiteboard photos off of my phone.)

Nautilus wasn't providing previews of the photos on the device which made it hard to find the photos I was looking for. To fix this, I went to nautilus preferences and turned on thumbnails for 'all' not just 'local files'. 

Nautilus froze up. So I pkill -9'ed it in a terminal and tried to browse the device again. Nautilus froze again when I went into the images folder on the phone. I killed nautilus again, and quickly went to Nautilus' preferences menu and turned off thumbnailing while it started thumbnailing the photos folder. After a few seconds my screen went black and i got what looks like a kernel oops / panic with gnome-shell traceback underneath.

I'm attaching a photo of the kernel spew and gnome-shell traceback.

Version-Release number of selected component (if applicable):

I've updated to kernel.x86_64 3.3.1-3.fc16 - there aren't any gnome-bluetooth / bluez updates available. I'll try again with the new kernel and see if it works.
Comment 1 Máirín Duffy 2012-04-10 10:56:52 EDT
I tried to reproduce with the new kernel and it doesn't seem to be happening as of yet. Although now I can not get the photos off of the device anymore: when I click on them in nautilus i get an error message along the lines of:

"No images found in 'obex://[90:21:55:2F:52:96]/DCIM/100MEDIA/IMAG2314.jpg'."

Sometimes I get an 'operation in progress' message. I think that it has a (considerably slow) operation running to generate thumbnails for the images, and trying to open up or transfer to my local machine any image doesn't interrupt that operation, instead it throws up an error message. 

Sometimes I get 'Failed to open input stream for file' when I click on it. 

Well, something funky is going on, I hope this bug report is useful.
Comment 2 Dave Jones 2012-04-10 11:22:35 EDT
The oops should be fixed (bug 806033)

No idea about the 'not working' part of the bug though.
Comment 3 Dave Jones 2012-10-23 11:32:44 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 4 Justin M. Forbes 2012-11-14 10:17:29 EST
With no response, we are closing this bug under the assumption that it is no longer an issue. If you still experience this bug, please feel free to reopen the bug report.

Note You need to log in before you can comment on or make changes to this bug.