Bug 811294 - [kn_IN] missing the Kannada Language rhsm.mo file
[kn_IN] missing the Kannada Language rhsm.mo file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
: i18n
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-04-10 12:11 EDT by John Sefler
Modified: 2012-06-20 09:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:09:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0804 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2012-06-19 15:51:31 EDT

  None (edit)
Description John Sefler 2012-04-10 12:11:36 EDT
Description of problem:
Did subscription-manager support for Knin language get removed from rhsm on purpose?


Version-Release number of selected component (if applicable):
[root@jsefler-63server ~]# rpm -q subscription-manager
subscription-manager-0.99.13-1.git.3.c07dbeb.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-63server ~]# rpm -ql subscription-manager | grep rhsm.mo
/usr/share/locale/as/LC_MESSAGES/rhsm.mo
/usr/share/locale/bn/LC_MESSAGES/rhsm.mo
/usr/share/locale/de/LC_MESSAGES/rhsm.mo
/usr/share/locale/es/LC_MESSAGES/rhsm.mo
/usr/share/locale/fr/LC_MESSAGES/rhsm.mo
/usr/share/locale/gu/LC_MESSAGES/rhsm.mo
/usr/share/locale/hi/LC_MESSAGES/rhsm.mo
/usr/share/locale/it/LC_MESSAGES/rhsm.mo
/usr/share/locale/ja/LC_MESSAGES/rhsm.mo
/usr/share/locale/ko/LC_MESSAGES/rhsm.mo
/usr/share/locale/ml/LC_MESSAGES/rhsm.mo
/usr/share/locale/mr/LC_MESSAGES/rhsm.mo
/usr/share/locale/or/LC_MESSAGES/rhsm.mo
/usr/share/locale/pa/LC_MESSAGES/rhsm.mo
/usr/share/locale/pt/LC_MESSAGES/rhsm.mo
/usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo
/usr/share/locale/ru/LC_MESSAGES/rhsm.mo
/usr/share/locale/ta/LC_MESSAGES/rhsm.mo
/usr/share/locale/te/LC_MESSAGES/rhsm.mo
/usr/share/locale/zh_CN/LC_MESSAGES/rhsm.mo
/usr/share/locale/zh_TW/LC_MESSAGES/rhsm.mo
[root@jsefler-63server ~]# 


Expected results:
Expected the following translation file for Knin language to be included in the list above.
/usr/share/locale/kn/LC_MESSAGES/rhsm.mo


Additional info:
Comment 1 Adrian Likins 2012-04-10 13:37:21 EDT
Looks like the kn.po file has an error in it:


kn
po/kn.po:713: end-of-line within string
msgfmt: found 1 fatal error

Figuring out how to fix that.
Comment 2 Adrian Likins 2012-04-10 14:33:05 EDT
I'll pull the latest strings which seems to have fix the kn.po.


commit fbe983ff4cdf426c788982be33663c950418538d
Author: Adrian Likins <alikins@redhat.com>
Date:   Tue Apr 10 14:29:31 2012 -0400

    811294: refresh strings to fix broken kn.po
Comment 6 John Sefler 2012-04-11 18:40:41 EDT
Verifying Version...
[root@jsefler-r63-server ~]# rpm -q subscription-manager
subscription-manager-0.99.14-1.el6.x86_64


[root@jsefler-r63-server ~]# rpm -ql subscription-manager | grep rhsm.mo | grep kn
/usr/share/locale/kn/LC_MESSAGES/rhsm.mo
[root@jsefler-r63-server ~]# 
[root@jsefler-r63-server ~]# LANG=kn_IN.UTF-8 subscription-manager --help


ಬಳಕೆ: subscription-manager MODULE-NAME [MODULE-OPTIONS] [--help]


ಪ್ರಾಥಮಿಕ ಮಾಡ್ಯೂಲ್‌ಗಳು:

	list           ಈ ಗಣಕಯಂತ್ರಕ್ಕಾಗಿನ ಚಂದಾದಾರಿಕೆ ಹಾಗು ಉತ್ಪನ್ನ ಮಾಹಿತಿಯನ್ನು ಪಟ್ಟಿ ಮಾಡಿ
	refresh        ಇತ್ತೀಚಿನ ಚಂದಾದಾರ ದತ್ತಾಂಶವನ್ನು ಪರಿಚಾರಕದಿಂದ ಪಡೆದುಕೊ
	register       ಕ್ಲೈಂಟ್‌ ಅನ್ನು RHN ಗೆ ನೋಂದಾಯಿಸಿ
	release        ಯಾವ os ಬಿಡುಗಡೆಗಳನ್ನು ಬಳಸಬೇಕು ಎನ್ನುವುದನ್ನು ಸಂರಚಿಸಿ
	subscribe      ನೋಂದಾಯಿಸಲಾದ ಗಣಕಯಂತ್ರವನ್ನು ಸೂಚಿಸಲಾದ ಉತ್ಪನ್ನಕ್ಕೆ ಚಂದಾದಾರವಾಗಿಸು
	unregister     ಕ್ಲೈಂಟ್‌ನ RHN ನೋಂದಣಿಯನ್ನು ರದ್ದುಗೊಳಿಸಿ
	unsubscribe    ಗಣಕಯಂತ್ರವನ್ನು ಎಲ್ಲಾ ಅಥವ ನಿಶ್ಚಿತ ಚಂದಾದಾರಿಕೆಗಳಿಂದ ರದ್ದುಗೊಳಿಸಿ

ಇತರೆ ಮಾಡ್ಯೂಲ್‌ಗಳು (ದಯವಿಟ್ಟು ದಸ್ತಾವೇಜನ್ನು ನೋಡಿ):

	clean          ಪರಿಚಾರಕದ ಮೇಲೆ ಪರಿಣಾಮ ಬೀರದೆ ಎಲ್ಲಾ ಸ್ಥಳೀಯ ಬಳಕೆದಾರ ಹಾಗು ಚಂದಾದಾರಿಕೆ ದತ್ತಾಂಶವನ್ನು ತೆಗೆದುಹಾಕು
	config         ಈ ಗಣಕಯಂತ್ರದಿಂದ ಬಳಸಲಾಗುತ್ತಿರುವ ನಿಯತಾಂಕಗಳ ಸಂರಚನೆಯನ್ನು ಪಟ್ಟಿ ಮಾಡಿ, ಹೊಂದಿಸಿ, ಅಥವ ತೆಗೆದುಹಾಕಿ.
	environments   ಬಳಕೆದಾರರಿಗೆ ಲಭ್ಯವಿರುವ ಪರಿಸರಗಳನ್ನು ತೋರಿಸು
	facts          ಈ ಗಣಕಯಂತ್ರಕ್ಕಾಗಿನ ಪ್ರಸಕ್ತ ವಸ್ತುಸ್ಥಿತಿಯ ಮೇಲೆ ಕೆಲಸಮಾಡು
	identity       ಈ ಗಣಕಕ್ಕಾಗಿ ಗುರುತಿನ ಪ್ರಮಾಣಪತ್ರವನ್ನು ತೋರಿಸು ಅಥವ ಒಂದು ಹೊಸ ಪ್ರಮಾಣಪತ್ರಕ್ಕಾಗಿ ಮನವಿ ಮಾಡು
	import         ಉಪಕರಣದ ಹೊರಗೆ ಒದಗಿಸಲಾದ ಪ್ರಮಾಣಪತ್ರಗಳನ್ನು ಆಮದು ಮಾಡು
	orgs           ಯಾವ ಸಂಸ್ಥೆಯ ಪರವಾಗಿ ಬಳಕೆದಾರರು ನೋಂದಾಯಿಸಿದ್ದಾರೆ ಎನ್ನುವುದನ್ನು ತೋರಿಸು
	redeem         ಪೂರ್ವಸಂರಚಿತಗೊಂಡ ಗಣಕಯಂತ್ರಕ್ಕಾಗಿ ಒಂದು ಚಂದಾದಾರಿಕೆಯನ್ನು ಹಿಂಪಡೆದುಕೊಳ್ಳುವ ಪ್ರಯತ್ನ
	repos          ಈ ಗಣಕಯಂತ್ರವು ಬಳಸಲು ಅರ್ಹವಾದ ರೆಪೊಗಳ ಪಟ್ಟಿ ಮಾಡು
	service-level  ಈ ವ್ಯವಸ್ಥೆಗಾಗಿ ಸೇವೆಯ ಮಟ್ಟಗಳನ್ನು ವ್ಯವಸ್ಥಾಪಿಸು.

[root@jsefler-r63-server ~]# 


Moving to VERIFIED.    Knin is back!
Comment 9 errata-xmlrpc 2012-06-20 09:09:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.