Bug 811296 - Notify user that password needs to be reset in forms-based login
Notify user that password needs to be reset in forms-based login
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 12:15 EDT by Dmitri Pal
Modified: 2012-06-20 09:26 EDT (History)
4 users (show)

See Also:
Fixed In Version: ipa-2.2.0-10.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:26:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-04-10 12:15:46 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2608

We have a ticket, #2276, to allow resetting the password using forms-based login. As a step towards that it would be good to be able to detect that a reset is required. Right now it reports an incorrect password.
Comment 2 Rob Crittenden 2012-04-17 15:04:49 EDT
Two patches. The first is to add a new header, X-IPA-Rejection-Reason to rpcserver.py. The second has the UI interpret the reason code and display different messages.

master:
7b515bddbcec2499fb765be311b3d093edcf6db2
c64bcafa137474cf31cd99e7cd6c28a00add85ff

ipa-2-2:
d05a5c646087877abe3819116cfc84ef9b053567
bd84fb445845bffc03109f3c69201c45da46fd48
Comment 7 Martin Kosek 2012-04-25 07:50:29 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 8 Namita Soman 2012-05-03 09:47:05 EDT
verified using ipa-server-2.2.0-12.el6.x86_64

Got error:

Password expired

Please run kinit to reset the password and then try to login again.

If the problem persists, contact your administrator.
Comment 10 errata-xmlrpc 2012-06-20 09:26:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.